summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-05-19 19:08:55 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-05-20 20:40:52 +0200
commita293c35b9f0c3bcdb8dd3b9dfea7955d20293da2 (patch)
treee181d80be2994bd6e8e5a4cd969227ab136575a9
parentnet-libs/libnetconf2: add 2.1.11 (diff)
downloadgentoo-a293c35b.tar.gz
gentoo-a293c35b.tar.bz2
gentoo-a293c35b.zip
net-misc/netopeer2: add 2.1.23
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--net-misc/netopeer2/Manifest1
-rw-r--r--net-misc/netopeer2/netopeer2-2.1.23.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/netopeer2/Manifest b/net-misc/netopeer2/Manifest
index 11b445c4460a..5f8928e6ca09 100644
--- a/net-misc/netopeer2/Manifest
+++ b/net-misc/netopeer2/Manifest
@@ -1 +1,2 @@
DIST netopeer2-2.1.16.tar.gz 371327 BLAKE2B fb9022cdad297ce366c00efbb0394feaa4dcff766f35c614354ea83a31871f24e05893e418face4e14df4d677c84e254cd8058259cddbc86ab4c94903eabd0f5 SHA512 9d0f1ddd38db2e9ac9a15ca1d8929eb32f682dd47c491a475acc406849fac0bc5f61f15cfabdacdedafe572855cf31cff4294c34eda2cad61e7518b62f40f71d
+DIST netopeer2-2.1.23.tar.gz 375193 BLAKE2B 14407c1d4b6a382fd0f9cf1c5d2d5f5d0aea27bac7f9b5597fe500a227b9e990e82a87da0216b310abe66f88ab5116d2f4cf101f186b9264e77a67af656a1d64 SHA512 5dcd9850151b71fe25a286bd37b672191125abe6a9e52a815f9ee88fa8200da17016f5aacbe5bcd33767cddbd18833df71d4b06b1fed1b97536e494fa70ca22f
diff --git a/net-misc/netopeer2/netopeer2-2.1.23.ebuild b/net-misc/netopeer2/netopeer2-2.1.23.ebuild
new file mode 100644
index 000000000000..f2d625e240a2
--- /dev/null
+++ b/net-misc/netopeer2/netopeer2-2.1.23.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Server for implementing NETCONF configuration management"
+HOMEPAGE="https://github.com/CESNET/netopeer2"
+SRC_URI="https://github.com/CESNET/netopeer2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/openssl:=
+ net-misc/curl:=
+ >=net-misc/sysrepo-2.1.64
+ >=net-libs/libnetconf2-2.1.11
+ net-libs/libssh:=
+ >=net-libs/libyang-2.0.194"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGENERATE_HOSTKEY=OFF
+ -DINSTALL_MODULES=OFF
+ -DMERGE_LISTEN_CONFIG=OFF
+ -DENABLE_TESTS=OFF
+ -DENABLE_VALGRIND_TESTS=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/netopeer2
+ doins -r scripts/.
+}
+
+pkg_postinst() {
+ elog "In order to do initial server setup please"
+ elog "run setup scripts located in /etc/netopeer2"
+}