summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-12 15:22:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-12 17:31:04 +0100
commita2bb78a5f8e547f5be00e8645028b2887c114e6b (patch)
tree867e947908311f5cbc0c7085144723d1b0888724
parentkde-plasma/kwayland: 6.0.2 version bump (diff)
downloadgentoo-a2bb78a5f8e547f5be00e8645028b2887c114e6b.tar.gz
gentoo-a2bb78a5f8e547f5be00e8645028b2887c114e6b.tar.bz2
gentoo-a2bb78a5f8e547f5be00e8645028b2887c114e6b.zip
kde-plasma/kwayland-integration: 6.0.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-6.0.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index 9d9cd44b62f0..a45a4fbbb891 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,3 +1,4 @@
DIST kwayland-integration-5.27.10.tar.xz 25776 BLAKE2B dbd1b2cedf1128f59318e41036bde63c8062538804a6b26418bce2210860a0b0f1dcbf217f9b823924ec8865b2bc3d6ceae7a06339d8ea1a508d67763e697027 SHA512 c66b08ba2af7675add7d603e0b8bdd20578abfc71af15574c389c8bec9856f309fe856c236f9fc8832e38c0125f5d55a3cc3d649b9d49733ee93d656b9c293fe
DIST kwayland-integration-5.27.11.tar.xz 25708 BLAKE2B 67fe2d113955b2cdec1c3d621efbe84b2565aa3f22e0d15eb95f1a2bce1a6c7fe87da9c2974d93fb2f1939d92d64d2ab2a2a1db609df5973ded5ac4a02f214cf SHA512 c5f19a03e8161b346dbd89fb0d1b72d7906c19a7d55535878d9d75b7d96025d61808161f6b0ccaf9b5fef1d112f8e0ba1033ce149e42aec2cd261351d5ffb1c9
DIST kwayland-integration-6.0.1.tar.xz 26420 BLAKE2B 09e7e0479de0f8227fbd54a6bb057b569a60617db955b32de9de80bbd8791ff9873eb37954e7e4acdfa281208d3e30c1518340f1579f99ade4c18d1bf892e10d SHA512 55728eb0f6a40a643d66efa96cd80a2a5d9ae3f59425bd2823556c09d4eb1c54583bcf19121679932b11f71b5946fd3fc3718a70ca11d684c7a44e637e9a42a2
+DIST kwayland-integration-6.0.2.tar.xz 26404 BLAKE2B 411c3fc9b12ea109d9b5ae13c437262368952113e6ba7097b47787ada6e699f90965af71c0f075edde8b7da030bd3c1c3327fa08b63b8b17a9b04e490f5337f0 SHA512 52990f567d1b95604f27f39381eb9916b1f1d6f3426a3dca30fca8abfdcfa1b89d62509f94bf289ffae13f6546b53cea42be4e33c253d726d890352858b56973
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-6.0.2.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-6.0.2.ebuild
new file mode 100644
index 000000000000..2ce54ec08c7a
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-6.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.115.0
+QTMIN=5.15.12
+inherit ecm flag-o-matic plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ >=kde-plasma/kwayland-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/plasma-wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ filter-lto # bug 921430
+ ecm_src_configure
+}