summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-01-01 20:36:43 -0500
committerVirgil Dupras <vdupras@gentoo.org>2019-01-01 20:36:43 -0500
commita2c8bad7e9615877c9007a19d65718a3a1b09c9b (patch)
tree81a6457eb130ab500c60b032f392b6773876ce32
parentdev-python/pillow: bump to 5.4.0 (diff)
downloadgentoo-a2c8bad7e9615877c9007a19d65718a3a1b09c9b.tar.gz
gentoo-a2c8bad7e9615877c9007a19d65718a3a1b09c9b.tar.bz2
gentoo-a2c8bad7e9615877c9007a19d65718a3a1b09c9b.zip
dev-python/pillow: fix broken tests
Starting with pytest 3.10, Pillow test suite breaks badly at collect time. It seems to be related to the way pytest was invoked. Bringing invocation closer to upstream's, that is, without specifying test unit files, makes test run alright. I fixed the invocation in 5.3 and, since 5.2 is already stabilized, added a version constraint on pytest. The newly bumped v5.4 already has a correct pytest invocation. Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-python/pillow/pillow-5.2.0.ebuild4
-rw-r--r--dev-python/pillow/pillow-5.3.0.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/pillow/pillow-5.2.0.ebuild b/dev-python/pillow/pillow-5.2.0.ebuild
index 5099bb0a2777..8a22a6354a30 100644
--- a/dev-python/pillow/pillow-5.2.0.ebuild
+++ b/dev-python/pillow/pillow-5.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,7 +39,7 @@ DEPEND="${RDEPEND}
dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
)
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
+ <dev-python/pytest-3.10[${PYTHON_USEDEP}]
media-gfx/imagemagick[png]
)
"
diff --git a/dev-python/pillow/pillow-5.3.0.ebuild b/dev-python/pillow/pillow-5.3.0.ebuild
index d05df3d9e900..a878b774c31f 100644
--- a/dev-python/pillow/pillow-5.3.0.ebuild
+++ b/dev-python/pillow/pillow-5.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -75,7 +75,7 @@ python_compile_all() {
python_test() {
"${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
# no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
- virtx pytest -vx Tests/test_*.py -p no:relaxed
+ virtx pytest -vv -p no:relaxed
}
python_install() {