summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-05 19:49:06 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-05 19:56:08 +0200
commita2ccc9280787c4488df5d8116c1080cb83c352df (patch)
tree17a79b2066362b372b73b3e7172adef432445830
parentdev-ruby/ffi: cleanup (diff)
downloadgentoo-a2ccc928.tar.gz
gentoo-a2ccc928.tar.bz2
gentoo-a2ccc928.zip
dev-ruby/redcloth: cleanup
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
-rw-r--r--dev-ruby/redcloth/redcloth-4.3.2.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-ruby/redcloth/redcloth-4.3.2.ebuild b/dev-ruby/redcloth/redcloth-4.3.2.ebuild
deleted file mode 100644
index 4b32b1cae1fd..000000000000
--- a/dev-ruby/redcloth/redcloth-4.3.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ruby25: not compatible
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_NAME="RedCloth"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGELOG"
-
-RUBY_FAKEGEM_REQUIRE_PATHS="lib/case_sensitive_require"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="A module for using Textile in Ruby"
-HOMEPAGE="http://redcloth.org/"
-
-GITHUB_USER=jgarber
-SRC_URI="https://github.com/${GITHUB_USER}/redcloth/archive/v${PV}.tar.gz -> ${RUBY_FAKEGEM_NAME}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND+=" =dev-util/ragel-6*"
-
-ruby_add_bdepend "
- >=dev-ruby/rake-0.8.7
- >=dev-ruby/rake-compiler-0.7.1
- test? ( >=dev-ruby/diff-lcs-1.1.2 )"
-
-pkg_setup() {
- ruby-ng_pkg_setup
-
- # Export the VERBOSE variable to avoid remapping of stdout and
- # stderr, and that breaks because of bad interactions between
- # echoe, Ruby and Gentoo.
- export VERBOSE=1
-}
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile ${PN}.gemspec || die
- rm -f tasks/{release,rspec,rvm}.rake || die
-}
-
-each_ruby_compile() {
- # We cannot run this manually easily, because Ragel re-generation
- # is a mess
- ${RUBY} -S rake compile || die "rake compile failed"
-}