summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-26 11:51:31 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-26 12:10:55 +0200
commita2cd10ad1544f8f31e0bccc3bdf76a4afa5b89fd (patch)
tree2da41007a89cca76f1789d7f0ca73f881fadf8b8
parentsys-kernel/gentoo-kernel-bin: Bump to 5.7.6 (diff)
downloadgentoo-a2cd10ad.tar.gz
gentoo-a2cd10ad.tar.bz2
gentoo-a2cd10ad.zip
dev-python/hypothesis: Bump to 5.18.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.18.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 75051bc37ff9..8d0b41a602c3 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -9,3 +9,4 @@ DIST hypothesis-python-5.16.1.tar.gz 9011388 BLAKE2B 9d80cd296475846404ded5c466e
DIST hypothesis-python-5.16.2.tar.gz 9011495 BLAKE2B ecac1ddd0c214a06e8822fc04f9fd9378933b1c3721c1a3aabfa605d45df21b22b76a497f5fa1bef3009ceba52d582c9f69a0918fdcaf7df7b3c03405f8eb7a9 SHA512 91feb7b81c4c36468b05318c0db7ce3b607374b55bf2609bb587d316448f087fab44b99cde1cb5fc440df8d31ef2dd6c154281f13dd7bc6d1de4e463cdabf66a
DIST hypothesis-python-5.16.3.tar.gz 9011952 BLAKE2B d74a68c4ee1e5aacf4be1da5a4656011b0a15f990106c21298101d36e9a097c5dfd165987ad90a45f3a0b74375c4da609cd750f618242b94f34e03b6de0ee866 SHA512 912d984995d4ad8f06e98eb2cc327629328990fc1c072527ce261b637e16622acaf4d0d93928f9dd2d6601ab78f69aa6cf129d5cd7c1c00e50754ebc06957df0
DIST hypothesis-python-5.18.0.tar.gz 9013356 BLAKE2B 3863414e54e40ac5f2a45edbb57fbee058e82f04cbde9eadb99ed6b03a2a2684777b46eabdbe136aea74b835e343485d80cfe98c263afa537c7437e7566f796f SHA512 b1a1f37f1f58a6401a31f32ef0e7de452b8a8bd71fe5aeb72eeac197a23b78c3ff17b61f7940e2a2a755f7f008f0ea3df5b0f2ad5e4c0d2d316bf13dbd7cbdaf
+DIST hypothesis-python-5.18.1.tar.gz 9013452 BLAKE2B a513c19a19b3ff49c78d97839dea7d857d9a00f7d42e5e0376cd6fec9ff9a86f9b6b9471da474ec7724e41254105c0ac65fc7d772f01bfc40f6deda200f11629 SHA512 19455699ed50d30767edc5627f797992f2542aeb3ca9e38603a68ffe1108f0287baa183e4dca101f21eaea6c7c7501e135b5baf9e09117a2cae92ec1e437e8b5
diff --git a/dev-python/hypothesis/hypothesis-5.18.1.ebuild b/dev-python/hypothesis/hypothesis-5.18.1.ebuild
new file mode 100644
index 000000000000..494668bd6a8e
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.18.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}