summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-07-24 13:59:34 -0500
committerBen Kohler <bkohler@gentoo.org>2022-07-25 09:26:22 -0500
commita2f751d2fa89bff3420d567eb1064b1ca89f0aaa (patch)
tree69db0f3cb75c2f945de2c6a1441bdf5ef8a231fd
parentapp-admin/mcelog: drop 181, 183 (diff)
downloadgentoo-a2f751d2fa89bff3420d567eb1064b1ca89f0aaa.tar.gz
gentoo-a2f751d2fa89bff3420d567eb1064b1ca89f0aaa.tar.bz2
gentoo-a2f751d2fa89bff3420d567eb1064b1ca89f0aaa.zip
app-cdr/dumpet: update EAPI 6 -> 8
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--app-cdr/dumpet/dumpet-2.1_p20140601-r4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-cdr/dumpet/dumpet-2.1_p20140601-r4.ebuild b/app-cdr/dumpet/dumpet-2.1_p20140601-r4.ebuild
new file mode 100644
index 000000000000..d54bc94cdc0b
--- /dev/null
+++ b/app-cdr/dumpet/dumpet-2.1_p20140601-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs vcs-snapshot
+
+COMMIT="8f47670dd582c96ad1b6dd3c9b9da0acebded5d8"
+
+DESCRIPTION="A tool to dump and debug bootable CD-like images"
+HOMEPAGE="https://github.com/rhboot/dumpet"
+SRC_URI="https://github.com/rhboot/dumpet/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+#Restrict tests since required test file is unavailable
+RESTRICT="test"
+
+BDEPEND="virtual/pkgconfig
+ test? ( dev-util/valgrind )"
+DEPEND="dev-libs/libxml2
+ dev-libs/popt"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/musl-byteswap-fix.patch )
+
+src_prepare() {
+ sed -i Makefile \
+ -e "s/^install : all$/install :/" \
+ -e "s/^CFLAGS:=/CFLAGS?=/" \
+ -e "s/^CC:=/CC?=/" \
+ -e '/^LFLAGS/ s/$/$(LDFLAGS)/' \
+ || die
+ default
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" dumpet
+}
+
+pkg_setup() {
+ tc-export CC
+}