summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-30 09:51:32 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-30 09:52:09 +0200
commita2f860b264487bbb9cd034971a699056224aebb7 (patch)
treedbd08b2495493d8d192ce851f36794f914c74825
parentmedia-video/yle-dl: add 20240429 (diff)
downloadgentoo-a2f860b264487bbb9cd034971a699056224aebb7.tar.gz
gentoo-a2f860b264487bbb9cd034971a699056224aebb7.tar.bz2
gentoo-a2f860b264487bbb9cd034971a699056224aebb7.zip
sci-misc/jupyterlab-desktop-bin: add 4.1.8.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest1
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.1.8.1.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
index 82e897ea78f3..9ff11cc3599e 100644
--- a/sci-misc/jupyterlab-desktop-bin/Manifest
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -1,2 +1,3 @@
DIST jupyterlab-desktop-bin-4.1.4.1.rpm 333180169 BLAKE2B 21b0f79ba9d0feebb1554ab0e11559e7c4b8898da59face94bb422bef0673ffbb6036ab24956b1e88a0387da903b0008aa24ff5905e44b3a594c19282da749b2 SHA512 725b082a664826c25f6e7c6564be5bf8df2dccb32a34623da4e82c8a961a52a2360be44f2b185048000a9fe7e1c02b0564ef519e6d4a8f0389e94b4447415d9c
DIST jupyterlab-desktop-bin-4.1.5.1.rpm 333125797 BLAKE2B 3aa27180799a28c6363730ce48333270f1e817dac1fc1c0b088a85b80bc35ce49b15e407c4b21bed480a09050449ad3032e77ab5985459572268970f2bbd1cd9 SHA512 0df094201fb4ee84c483306c3fb90daa32ca4ea3e2b461b8709b5e829513918d719b89de4c75eb3f63956345bbcac19aeb7c714201eded390de971dcb3173093
+DIST jupyterlab-desktop-bin-4.1.8.1.rpm 332883125 BLAKE2B e0d46f6eb1718b5f2e2b00b1ac934bfa3bab12b2d5e9c0cafd2874a67cc1fc8a1aabc5ac9d5d3ac4abf53b262a8e5cdc8d27ef4c2cdc30a069420f2227dffed2 SHA512 9a6fa8729c4cab9df7643bbc1c2094e438ff9136b7c2f5897a5e0603ad8740e3ed46b6fe7a01885c063d0df6310dca8fe4aadb45da76c1543841b9eb7d70080d
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.1.8.1.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.1.8.1.ebuild
new file mode 100644
index 000000000000..fba316a220ed
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.1.8.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv
+ sw ta te th tr uk ur vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora-x64.rpm -> ${P}.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+# Electron bundles a bunch of things
+LICENSE="
+ MIT BSD BSD-2 BSD-4 AFL-2.1 Apache-2.0 Ms-PL GPL-2 LGPL-2.1 APSL-2
+ unRAR OFL CC-BY-SA-3.0 MPL-2.0 android public-domain all-rights-reserved
+"
+SLOT="0"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ >=dev-python/jupyterlab-$(ver_cut 1-3)
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/JupyterLab/*"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ # cleanup languages
+ pushd "opt/JupyterLab/locales" || die
+ chromium_remove_language_paks
+ popd || die
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ local size=512
+ doicon -s ${size} "usr/share/icons/hicolor/${size}x${size}/apps/jupyterlab-desktop.png"
+
+ domenu usr/share/applications/jupyterlab-desktop.desktop
+
+ local DESTDIR="/opt/JupyterLab"
+ pushd "opt/JupyterLab" || die
+
+ exeinto "${DESTDIR}"
+ doexe chrome-sandbox chrome_crashpad_handler jupyterlab-desktop *.so*
+
+ insinto "${DESTDIR}"
+ doins *.pak *.bin *.json *.dat
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set.
+ # see https://github.com/electron/electron/issues/17972
+ fperms 4755 "${DESTDIR}"/chrome-sandbox
+
+ dosym "${DESTDIR}"/jupyterlab-desktop /opt/bin/jupyterlab-desktop
+ popd || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}