summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-26 21:47:28 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-26 23:57:49 -0800
commita2fe5b7ff098c8b7e7444a89badc40977ab2e0ba (patch)
tree60437f0d60da2ff0a51277798bc0df6295e963ca
parentdev-python/dnspython-1.16.0-r1: revbump, add py38 (diff)
downloadgentoo-a2fe5b7f.tar.gz
gentoo-a2fe5b7f.tar.bz2
gentoo-a2fe5b7f.zip
dev-python/greenlet-0.4.15-41: revbump, cleanups, py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/greenlet/greenlet-0.4.15-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/greenlet/greenlet-0.4.15-r1.ebuild b/dev-python/greenlet/greenlet-0.4.15-r1.ebuild
new file mode 100644
index 000000000000..e123a0d5fe0f
--- /dev/null
+++ b/dev-python/greenlet/greenlet-0.4.15-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Note: greenlet is built-in in pypy
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Lightweight in-process concurrent programming"
+HOMEPAGE="https://pypi.org/project/greenlet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+distutils_enable_sphinx doc
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
+ append-flags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ "${PYTHON}" run-tests.py -n || die "Tests fail with ${EPYTHON}"
+}