summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-08-30 12:59:25 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-08-30 12:59:34 +0200
commita30252e5a66bf4551c9598841f7027237ff34369 (patch)
treed48e7058cbc78c288bcad344eee71824e4e0990b
parentsys-fs/udiskie: fix DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-a30252e5.tar.gz
gentoo-a30252e5.tar.bz2
gentoo-a30252e5.zip
games-emulation/dosbox-staging: 0.77.1 bump
Bugfixes release Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--games-emulation/dosbox-staging/Manifest1
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/games-emulation/dosbox-staging/Manifest b/games-emulation/dosbox-staging/Manifest
index ebdefbfb3fc0..0ef607994d30 100644
--- a/games-emulation/dosbox-staging/Manifest
+++ b/games-emulation/dosbox-staging/Manifest
@@ -1,2 +1,3 @@
DIST dosbox-staging-0.76.0.tar.gz 1908605 BLAKE2B 71b3c3d6a6444e2442d54b1db365ea66c9ee3db703be876facb8425355d82d817c080e005cefd103714e15fc7d1c17d6329c28d67bf74c143d0428e4f58e5142 SHA512 8c0357bcec08cac2cd2b306edd8b51ad05e16a3c3efb1f4c77e1d942f285493cae8aab45f1633e9c168c0b4b45aa289cf3ffc72685dc004d83127cdb6c76ae9d
DIST dosbox-staging-0.77.0.tar.gz 2579927 BLAKE2B 2a8381451ec110ca5350afc70c45f158329bd273b381ff61856ab721a0b194c7d501402453e9a36b90663ee8f6697dce8f64b05adf56efa8df2fd68161e420b6 SHA512 37259fecc091f1e318c2385d6e6fdc3b4ad0905ce63a7db1fc812c924bf8c01640692aca4f08b87d06e6001e50f3f2f4bb63c3715aa9cdfeebd205ed345558a0
+DIST dosbox-staging-0.77.1.tar.gz 2622418 BLAKE2B c56020d263ceac199266a5c458c192441f836ea2e71e1564da175b7ae522286ca1b6a07062498ccea795bbf330beecb5ef99a0130637b1df26603315d48ea6ff SHA512 fe5d6150a88f5c276aee5672f98c15b5ffee702fe9934919d3e78068efd1a85f08a8f04352bc6a8fe850324e33f3227340c59242db6cbae0475b12a58b749cac
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
new file mode 100644
index 000000000000..5815a612b2b1
--- /dev/null
+++ b/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit meson xdg
+
+DESCRIPTION="Modernized DOSBox soft-fork"
+HOMEPAGE="https://dosbox-staging.github.io/"
+SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa debug dynrec +fluidsynth mt-32 network opengl"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ debug? ( sys-libs/ncurses:0= )
+ fluidsynth? (
+ media-sound/fluid-soundfont
+ media-sound/fluidsynth
+ )
+ mt-32? ( media-libs/munt-mt32emu )
+ network? ( media-libs/sdl2-net )
+ opengl? ( virtual/opengl )
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,opengl?,video,X]
+ media-libs/opusfile
+ sys-libs/zlib
+ !games-emulation/dosbox"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+DOCS=( AUTHORS README THANKS )
+
+src_prepare() {
+ default
+
+ # We do not have default.sf2, use actual name from fluid-soundfont
+ sed -e "s/default.sf2/FluidR3_GM.sf2/" \
+ -i src/midi/midi_fluidsynth.cpp || die
+
+ # Disable license and docs install (handled by ebuild)
+ sed -e "/licenses_dir\|doc_dir/d" -i meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use alsa use_alsa)
+ $(meson_use debug)
+ -Ddynamic_core=$(usex dynrec dynrec dyn-x86)
+ $(meson_use fluidsynth use_fluidsynth)
+ $(meson_use mt-32 use_mt32emu)
+ $(meson_use network use_sdl2_net)
+ $(meson_use opengl use_opengl)
+ )
+ meson_src_configure
+}