summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-05-29 14:04:08 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-05-29 14:04:20 -0400
commita31c1fdac2f410bf22c9fb388f5e094d8776a973 (patch)
tree5a7ca81c8b6a55ac533aaf1206a9cb8793d299fa
parentx11-drivers/xf86-video-omapfb: fix building against glibc-2.20 (diff)
downloadgentoo-a31c1fda.tar.gz
gentoo-a31c1fda.tar.bz2
gentoo-a31c1fda.zip
dev-go/goptlib: bump to version 0.6
Package-Manager: portage-2.2.28
-rw-r--r--dev-go/goptlib/Manifest1
-rw-r--r--dev-go/goptlib/goptlib-0.6.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-go/goptlib/Manifest b/dev-go/goptlib/Manifest
index bce2c2720c3d..2c490995a5a2 100644
--- a/dev-go/goptlib/Manifest
+++ b/dev-go/goptlib/Manifest
@@ -1 +1,2 @@
DIST goptlib-0.5.tar.gz 22487 SHA256 b9d264ebe61d601e38a94911efc4884753612c9e0dd1e2bddb6af14b823b715c SHA512 98443e06dbed3cdcc2652dd176e4ef89ba34b042c7886f7342a18ce319c91cf8004f2dd1eb58984685f03d25db272d23d2a9c5d872b28953f62c0b2f04be2c92 WHIRLPOOL e41c28f0e31f6133c1905b2e42072744bb647904759cc2223d730478b27bf237c6170bdac18274c15d80e0a7f41dd3bd7770480151d358c0f0f74c2a0f724af6
+DIST goptlib-0.6.tar.gz 25544 SHA256 88df4dbab81baaff71a9b07e5f60d8ada9eeaa83ce294cc4057a81a3b301cd87 SHA512 233aa4434559d64e5d5ec5a8e243ab44157e5e467a3d473adf65f9002440d2584c8cb6cd4b69a2224b33e21703835755e2a91eb3e959acbfad5052f64ad7bfbf WHIRLPOOL 79eb2680ddb82f666716ccf580b3ce76545282dae4eb4e795f2aaa45838be16de097109e3d68c6e513aa9df04a8b0bba7ca08540f104c04e6485eb50bc101108
diff --git a/dev-go/goptlib/goptlib-0.6.ebuild b/dev-go/goptlib/goptlib-0.6.ebuild
new file mode 100644
index 000000000000..3d2eaba8a8bb
--- /dev/null
+++ b/dev-go/goptlib/goptlib-0.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit golang-build golang-vcs-snapshot
+
+EGO_SRC=git.torproject.org/pluggable-transports/goptlib.git
+EGO_PN=${EGO_SRC}/...
+EGIT_COMMIT="${PV}"
+
+DESCRIPTION="Go Tor pluggable transports library"
+HOMEPAGE="https://gitweb.torproject.org/pluggable-transports/goptlib.git"
+# No official tarballs; see https://trac.torproject.org/projects/tor/ticket/18504
+SRC_URI="mirror://debian/pool/main/g/golang-${PN}/golang-${P/-/_}.orig.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""