summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-08-27 09:04:10 -0400
committerCraig Andrews <candrews@gentoo.org>2019-08-27 09:04:43 -0400
commita31c9aa8de9537fe1918546bd4895c187917eabb (patch)
tree65dbf05726f6aa94ef35ac98bc2499b1c3e1ef8b
parentapp-forensics/lynis: Version bump. Remove old (diff)
downloadgentoo-a31c9aa8.tar.gz
gentoo-a31c9aa8.tar.bz2
gentoo-a31c9aa8.zip
dev-libs/rocm-opencl-driver: Include more link libraries
Closes: https://bugs.gentoo.org/692404 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.7.0-libraries.patch40
-rw-r--r--dev-libs/rocm-opencl-driver/rocm-opencl-driver-2.7.0.ebuild1
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.7.0-libraries.patch b/dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.7.0-libraries.patch
new file mode 100644
index 000000000000..9e2a06aac979
--- /dev/null
+++ b/dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.7.0-libraries.patch
@@ -0,0 +1,40 @@
+https://github.com/RadeonOpenCompute/ROCm-OpenCL-Driver/pull/88
+
+From f49ad81e246f1c196cf86f40cf44dfedec0675f1 Mon Sep 17 00:00:00 2001
+From: Mike Lothain <mike@fireburn.co.uk>
+Date: Tue, 27 Aug 2019 11:32:47 +0100
+Subject: [PATCH] Include more link libraries
+
+This is required to get dev-libs/rocm-opencl-driver-2.7.0 compiling for me on Gentoo
+
+I think it might be related to using -Wl,--as-needed in my link flags globally
+---
+ src/driver/CMakeLists.txt | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/driver/CMakeLists.txt b/src/driver/CMakeLists.txt
+index 55ed13f..b93356d 100644
+--- a/src/driver/CMakeLists.txt
++++ b/src/driver/CMakeLists.txt
+@@ -60,9 +60,13 @@ llvm_map_components_to_libnames(llvm_libs
+ AllTargetsDescs
+ AllTargetsDisassemblers
+ AllTargetsInfos
++ BitWriter
+ CodeGen
++ IRReader
++ Linker
+ MC
+ MCDisassembler
++ MCParser
+ Object
+ Symbolize
+ Core
+@@ -83,6 +87,7 @@ target_link_libraries(opencl_driver
+ clangLex
+ clangBasic
+ clangCodeGen
++ clangSerialization
+ lldELF
+ lldCore
+ LLVMDebugInfoDWARF
diff --git a/dev-libs/rocm-opencl-driver/rocm-opencl-driver-2.7.0.ebuild b/dev-libs/rocm-opencl-driver/rocm-opencl-driver-2.7.0.ebuild
index f95628a7cb79..e4e2818a7ed7 100644
--- a/dev-libs/rocm-opencl-driver/rocm-opencl-driver-2.7.0.ebuild
+++ b/dev-libs/rocm-opencl-driver/rocm-opencl-driver-2.7.0.ebuild
@@ -28,6 +28,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-2.6.0-install-correctly.patch"
"${FILESDIR}/${PN}-2.6.0-install-header.patch"
+ "${FILESDIR}/${PN}-2.7.0-libraries.patch"
)
src_prepare() {