summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-03-31 01:26:49 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-03-31 01:27:22 +0200
commita31f6aab2671f7cea5d96ff7ca0410bc82df27f4 (patch)
tree9fe53c468bf487dbe7da59a6cf9bea1a939f2a67
parentdev-vcs/bzr: stable 2.7.0 for ppc64, bug #646764 (diff)
downloadgentoo-a31f6aab.tar.gz
gentoo-a31f6aab.tar.bz2
gentoo-a31f6aab.zip
app-admin/collectd: Fix pkg_postinst...
...to support systemd's new rootprefix. Closes: https://bugs.gentoo.org/596852 Package-Manager: Portage-2.3.26, Repoman-2.3.7 RepoMan-Options: --force
-rw-r--r--app-admin/collectd/collectd-5.7.2-r2.ebuild (renamed from app-admin/collectd/collectd-5.7.2-r1.ebuild)8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-admin/collectd/collectd-5.7.2-r1.ebuild b/app-admin/collectd/collectd-5.7.2-r2.ebuild
index aa1d44699653..9adfa6322e16 100644
--- a/app-admin/collectd/collectd-5.7.2-r1.ebuild
+++ b/app-admin/collectd/collectd-5.7.2-r2.ebuild
@@ -500,7 +500,7 @@ pkg_postinst() {
elog " ${caps_str}+EP"
elog
- local systemd_unit="${EROOT}usr/lib/systemd/system/collectd.service"
+ local systemd_unit="$(systemd_get_systemunitdir)/collectd.service"
if [[ -e "${systemd_unit}" ]]; then
caps_str="${caps[*]}"
sed -i -e "s:^CapabilityBoundingSet=.*:CapabilityBoundingSet=${caps_str}:" "${systemd_unit}" || \
@@ -509,6 +509,12 @@ pkg_postinst() {
elog "CapabilityBoundingSet in '${systemd_unit}'"
elog "updated to match capabilities set above."
elog
+ else
+ if has_version "sys-apps/systemd"; then
+ # Bug 596852
+ ewarn "Failed to update CapabilityBondingSet in '${systemd_unit}'"
+ ewarn "because unit was not found. Please file a bug about this."
+ fi
fi
fi
fi