summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-13 22:00:52 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-13 22:01:04 +0100
commita32410ac8b140c1cd8f2d5ea1a8adfec6f0ec193 (patch)
tree9077738d278b5b7f5113afa2b5b2fadf64560309
parentdev-ml/logs: fix build without lwt (diff)
downloadgentoo-a32410ac8b140c1cd8f2d5ea1a8adfec6f0ec193.tar.gz
gentoo-a32410ac8b140c1cd8f2d5ea1a8adfec6f0ec193.tar.bz2
gentoo-a32410ac8b140c1cd8f2d5ea1a8adfec6f0ec193.zip
dev-python/installer: New package, v0.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/installer/Manifest2
-rw-r--r--dev-python/installer/installer-0.4.0.ebuild43
-rw-r--r--dev-python/installer/metadata.xml13
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/installer/Manifest b/dev-python/installer/Manifest
new file mode 100644
index 000000000000..2d38fa076c4d
--- /dev/null
+++ b/dev-python/installer/Manifest
@@ -0,0 +1,2 @@
+DIST installer-0.4.0-py2.py3-none-any.whl.zip 451433 BLAKE2B 933b7e63b3d0306213789d493d4df112df26b432d63ecd1f8f21449520c34bd2ad542aac25069043fbb535c44f988dca927625eafd0a5a20489fc3ce2bcf84a2 SHA512 cf303bb422e329a36007b361034144a232ba021d4013bb8678dc7c326544e74ec9a3b3fe8b9d3696433dbbe90d2ce4a0ae8967fb054bd5ed49321d470be729a8
+DIST installer-0.4.0.gh.tar.gz 466643 BLAKE2B 635854b3461995cda3b7afa507ca3fe35cae8210e79de0bbd46938c8f103d7840ceca8bb388c2c9533efc78150691f980c478485ee33bafe0bae6c08a6aef8c4 SHA512 13537c479bc8ead8f8b45c8e5c5182e8b1b32c2889df8015be7f517f390a9efbea6fa167e0886dfade6621a8a2d822bfd662ee0238d3d86689619ca4d5483b26
diff --git a/dev-python/installer/installer-0.4.0.ebuild b/dev-python/installer/installer-0.4.0.ebuild
new file mode 100644
index 000000000000..366c9ebc1817
--- /dev/null
+++ b/dev-python/installer/installer-0.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A library for installing Python wheels"
+HOMEPAGE="
+ https://pypi.org/project/installer/
+ https://github.com/pradyunsg/installer/
+ https://installer.readthedocs.io/en/latest/
+"
+SRC_URI="
+ https://github.com/pradyunsg/installer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://files.pythonhosted.org/packages/py2.py3/${PN::1}/${PN}/${P}-py2.py3-none-any.whl
+ -> ${P}-py2.py3-none-any.whl.zip
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+distutils_enable_tests pytest
+
+# do not use any build system to avoid circular deps
+python_compile() { :; }
+
+python_test() {
+ local -x PYTHONPATH=src
+ epytest
+}
+
+python_install() {
+ python_domodule src/installer "${WORKDIR}"/*.dist-info
+}
diff --git a/dev-python/installer/metadata.xml b/dev-python/installer/metadata.xml
new file mode 100644
index 000000000000..090fe7139f47
--- /dev/null
+++ b/dev-python/installer/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">installer</remote-id>
+ <remote-id type="github">pradyunsg/installer</remote-id>
+ </upstream>
+</pkgmetadata>