summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-27 08:16:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-27 08:16:11 +0200
commita325918db95403d5e6f848d5f438cb926bf40f97 (patch)
treec055e4d4873d342f743806424136b121cb4ed6fd
parentxfce-base/exo: Bump to 4.17.0 (diff)
downloadgentoo-a325918d.tar.gz
gentoo-a325918d.tar.bz2
gentoo-a325918d.zip
dev-python/mkdocs: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mkdocs/mkdocs-1.1.2-r1.ebuild67
-rw-r--r--dev-python/mkdocs/mkdocs-1.1.2.ebuild58
2 files changed, 0 insertions, 125 deletions
diff --git a/dev-python/mkdocs/mkdocs-1.1.2-r1.ebuild b/dev-python/mkdocs/mkdocs-1.1.2-r1.ebuild
deleted file mode 100644
index 6d18515e6d89..000000000000
--- a/dev-python/mkdocs/mkdocs-1.1.2-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Project documentation with Markdown"
-HOMEPAGE="https://www.mkdocs.org https://github.com/mkdocs/mkdocs"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc"
-
-BDEPEND="
- doc? (
- dev-python/mdx_gh_links
- )
-"
-
-RDEPEND="
- >=dev-python/click-7.0[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10.3[${PYTHON_USEDEP}]
- >=dev-python/livereload-2.6.1[${PYTHON_USEDEP}]
- ~dev-python/lunr-0.5.9[${PYTHON_USEDEP}]
- >=dev-python/markdown-3.2.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.2[${PYTHON_USEDEP}]
- >=www-servers/tornado-5.1.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests nose
-
-python_prepare_all() {
- # Tests fails if additional themes are installed
- sed -i -e 's:test_get_themes:_&:' \
- mkdocs/tests/utils/utils_tests.py || die
-
- # Upstream pins this to workaround with a bug
- # in lunr, from 0.5.9 onwards lunr (mistakenly?)
- # depends on nltk<3.5 if [languages], which does not
- # work with mkdocs. We remove the [languages] part, and
- # allow the use of 0.5.9 instead of 0.5.8.
- # Tests pass.
- sed -i -e 's/lunr\[languages\]==0.5.8/lunr==0.5.9/g' \
- setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- default
- if use doc; then
- # cannot just do mkdocs build, because that fails if
- # the package isn't already installed
- python -m mkdocs build || die "Failed to make docs"
- # Colliding files found by ecompress:
- rm site/sitemap.xml.gz || die
- HTML_DOCS=( "site/." )
- fi
-}
diff --git a/dev-python/mkdocs/mkdocs-1.1.2.ebuild b/dev-python/mkdocs/mkdocs-1.1.2.ebuild
deleted file mode 100644
index 853c0a488f31..000000000000
--- a/dev-python/mkdocs/mkdocs-1.1.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Project documentation with Markdown"
-HOMEPAGE="https://www.mkdocs.org https://github.com/mkdocs/mkdocs"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-IUSE="doc"
-
-BDEPEND="
- doc? (
- dev-python/mdx_gh_links
- )
-"
-
-RDEPEND="
- >=dev-python/click-7.0[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10.3[${PYTHON_USEDEP}]
- >=dev-python/livereload-2.6.1[${PYTHON_USEDEP}]
- ~dev-python/lunr-0.5.8[${PYTHON_USEDEP}]
- >=dev-python/markdown-3.2.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.2[${PYTHON_USEDEP}]
- >=www-servers/tornado-5.1.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests nose
-
-python_prepare_all() {
- # Tests fails if additional themes are installed
- sed -i -e 's:test_get_themes:_&:' \
- mkdocs/tests/utils/utils_tests.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- default
- if use doc; then
- # cannot just do mkdocs build, because that fails if
- # the package isn't already installed
- python -m mkdocs build || die "Failed to make docs"
- # Colliding files found by ecompress:
- rm site/sitemap.xml.gz || die
- HTML_DOCS=( "site/." )
- fi
-}