summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-02 18:03:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-02 18:05:23 +0200
commita3291bab51e7c935eae5120768e62e744bce2f64 (patch)
treef39ae7f4253c8e8f27cdb9282800968b678aad5d
parentdev-python/boto3: Remove old (diff)
downloadgentoo-a3291bab.tar.gz
gentoo-a3291bab.tar.bz2
gentoo-a3291bab.zip
dev-python/botocore: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest3
-rw-r--r--dev-python/botocore/botocore-1.20.102.ebuild59
-rw-r--r--dev-python/botocore/botocore-1.20.103.ebuild59
-rw-r--r--dev-python/botocore/botocore-1.20.78.ebuild59
4 files changed, 0 insertions, 180 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 49762a1867bb..1f3afe26583c 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,5 +1,2 @@
-DIST botocore-1.20.102.tar.gz 7881122 BLAKE2B 51d2acb780766a02a2b58bab10c22557614711e944c58fdbd78479a59e1139446a642da7a8192f2d37c22fa8fa60d27024fca68737601d143018a17669f8df4c SHA512 ee756829454bca50e872cc8cb3caa66ff9ff3cc1075a1afdf693d39e4e9f3c7953b1c69c13c78be594aee572752eb89700369985dfc57e7ebc772b444f8d8c91
-DIST botocore-1.20.103.tar.gz 7882203 BLAKE2B 349de76a9e1cd664a8ad124f1b935289468df4bf37f23067efa2217d8c29ed39b3128796d83a54e5c59968c9f6fd396511956fb29cf114488ab1dee1b5e4951f SHA512 5d0543af8aa9ad0c4021b845e659136e05eb688604f32514e1895fa4bf4588b2901cbef05ec336dfe9326e3959d10bb78a9b4f772d75d40d6a53af1615d76c6a
DIST botocore-1.20.104.tar.gz 7883624 BLAKE2B 4fb4c6abff5a2c3d3e19b11576e723f15a442b2d49e461a2a4c2bd613e26095ceb87f4b7ceb672f338ea04ad918060bed118f7bc4c184c46cce1d6a9f98d4239 SHA512 2201d87ce2e1c8979548698d6a46eb03c0a2026360b178fea895ad6a244efad534d9970d3c6343d50639d25b3b8643db6744658fec14e0fa29fd7c4b45c8e0d8
-DIST botocore-1.20.78.tar.gz 7758829 BLAKE2B af13d6c1aa918e2c49c6dc931c9a78e1899c83e62657c063e20ba2a5544c48e4946018628e47d6a56db456a3a8d43fe3b577824bd76bbc339abaef375459932e SHA512 fc96ed8b6b4af05404654e470a4f83419b885fa32d9dc704727f4ffb3d5deeefa752d235b37fd81448b7f3b101bc0f8e7ea09ae8641f8961566f77f6a039cef9
DIST botocore-1.20.97.tar.gz 7846552 BLAKE2B da0355cc229ba8a0632f67866bf06b27d7b257184b53670e5dc183c6b5a1f4d3a34145de0a3f04abd2adc08de3f0775e3c7e0dbecae729acb5bc05c7ce9acaf2 SHA512 7411d5de8ecf0c42c0142ded036189dcf378cd16f761071beb5bc2a2c240eabb0c4a8c669ce89a5b4e798a0aae92f0e67755627c2a84df77fc2e9557265a4e3b
diff --git a/dev-python/botocore/botocore-1.20.102.ebuild b/dev-python/botocore/botocore-1.20.102.ebuild
deleted file mode 100644
index 30e0988848ad..000000000000
--- a/dev-python/botocore/botocore-1.20.102.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Low-level, data-driven core of boto 3"
-HOMEPAGE="https://github.com/boto/botocore"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/botocore"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/jmespath[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
-)
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests nose
-
-src_prepare() {
- # unpin deps
- sed -i -e "s:>=.*':':" setup.py || die
- # very unstable
- sed -i -e 's:test_stress_test_token_bucket:_&:' \
- tests/functional/retries/test_bucket.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- # note: suites need to be run separately as one of the unit tests
- # seems to be leaking mocks and breaking a few functional tests
- nosetests -v tests/unit ||
- die "unit tests failed under ${EPYTHON}"
- nosetests -v tests/functional ||
- die "functional tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/botocore/botocore-1.20.103.ebuild b/dev-python/botocore/botocore-1.20.103.ebuild
deleted file mode 100644
index 30e0988848ad..000000000000
--- a/dev-python/botocore/botocore-1.20.103.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Low-level, data-driven core of boto 3"
-HOMEPAGE="https://github.com/boto/botocore"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/botocore"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/jmespath[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
-)
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests nose
-
-src_prepare() {
- # unpin deps
- sed -i -e "s:>=.*':':" setup.py || die
- # very unstable
- sed -i -e 's:test_stress_test_token_bucket:_&:' \
- tests/functional/retries/test_bucket.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- # note: suites need to be run separately as one of the unit tests
- # seems to be leaking mocks and breaking a few functional tests
- nosetests -v tests/unit ||
- die "unit tests failed under ${EPYTHON}"
- nosetests -v tests/functional ||
- die "functional tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/botocore/botocore-1.20.78.ebuild b/dev-python/botocore/botocore-1.20.78.ebuild
deleted file mode 100644
index 42a1ef99e273..000000000000
--- a/dev-python/botocore/botocore-1.20.78.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Low-level, data-driven core of boto 3"
-HOMEPAGE="https://github.com/boto/botocore"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/botocore"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/jmespath[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
-)
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests nose
-
-src_prepare() {
- # unpin deps
- sed -i -e "s:>=.*':':" setup.py || die
- # very unstable
- sed -i -e 's:test_stress_test_token_bucket:_&:' \
- tests/functional/retries/test_bucket.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- # note: suites need to be run separately as one of the unit tests
- # seems to be leaking mocks and breaking a few functional tests
- nosetests -v tests/unit ||
- die "unit tests failed under ${EPYTHON}"
- nosetests -v tests/functional ||
- die "functional tests failed under ${EPYTHON}"
-}