summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-18 01:21:15 +0000
committerSam James <sam@gentoo.org>2023-12-21 11:49:38 +0000
commita33a0375fe3b4a45397e7dbd3e8162f24586ea1c (patch)
treebb39dbb8273c15b8f711d4bb6e9a0f65e68a5843
parentmate-base/caja: add 1.26.3, 1.27.2 (diff)
downloadgentoo-a33a0375fe3b4a45397e7dbd3e8162f24586ea1c.tar.gz
gentoo-a33a0375fe3b4a45397e7dbd3e8162f24586ea1c.tar.bz2
gentoo-a33a0375fe3b4a45397e7dbd3e8162f24586ea1c.zip
mate-base/libmatekbd: add 1.27.1
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--mate-base/libmatekbd/Manifest1
-rw-r--r--mate-base/libmatekbd/libmatekbd-1.27.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/mate-base/libmatekbd/Manifest b/mate-base/libmatekbd/Manifest
index 3c9575aa9cd1..94d6adbf6cb8 100644
--- a/mate-base/libmatekbd/Manifest
+++ b/mate-base/libmatekbd/Manifest
@@ -1 +1,2 @@
DIST libmatekbd-1.26.0.tar.xz 453996 BLAKE2B 42b3933d27bde000cc599ba42223f01312db7d9b7a395378af4def91063dcdedeff66be43d35e6a763826c3fc0eafd354731c634a73a1d0b524a0cff6e38cc2d SHA512 1e8bdb331ecb97ccd54931ac59f0692af8665e7c0499a62b25ac69cfc6af1196b5198d707ef5e3985d8fe837a0813a014802b00760d32924af4f38b0df4b8b65
+DIST libmatekbd-1.27.1.tar.xz 461752 BLAKE2B 112339dd59ada550873902ebf3d757343e6db709a0ad6e60a4862c21fe54d83054e39091e99decacca5cd74011e4541323b8d1bf0b7efb236c56c35a67da1103 SHA512 df8e43718897d54a0a3c11d3ee2bda296ae5b7e9c7e9da1f9caaa784631a135d9074cdecf7f39747987e822b8f7759881a5e93c02b7671e7a7efdc90fe77f2c8
diff --git a/mate-base/libmatekbd/libmatekbd-1.27.1.ebuild b/mate-base/libmatekbd/libmatekbd-1.27.1.ebuild
new file mode 100644
index 000000000000..5a11caba4678
--- /dev/null
+++ b/mate-base/libmatekbd/libmatekbd-1.27.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE keyboard configuration library"
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="X +introspection test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ virtual/libintl
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.24:2
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5.2:0[introspection?]
+ x11-libs/pango
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ $(use_with X x) \
+ $(use_enable introspection) \
+ $(use_enable test tests)
+}