summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-29 05:57:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-29 05:57:17 +0100
commita33e8e6f2d2527a1b9f3ecbc2b334453007fdc37 (patch)
treeb1d77af17150927773a8937ed5ea31d4b4807dac
parentapp-alternatives/sh: change eselect-sh blocker from hard to soft (diff)
downloadgentoo-a33e8e6f2d2527a1b9f3ecbc2b334453007fdc37.tar.gz
gentoo-a33e8e6f2d2527a1b9f3ecbc2b334453007fdc37.tar.bz2
gentoo-a33e8e6f2d2527a1b9f3ecbc2b334453007fdc37.zip
dev-python/botocore: Bump to 1.29.39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.39.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index af20f85dfa19..2f275a05ed10 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -7,3 +7,4 @@ DIST botocore-1.29.34.gh.tar.gz 11061036 BLAKE2B 03b4b48d1308113be6711e27d15dfca
DIST botocore-1.29.36.gh.tar.gz 11075582 BLAKE2B 4db73c753acc1eba93bc5fc3a2486b3ded6ee41e35220f56cefc71e808128cb88582474782b1e77b992186b8bcab3ec34ec5566517b1464ee226480f615ef1f0 SHA512 dfaf655fabe85c54cc58a4266fa11b78c7b0dab771a639d9bf8d2583db1b245ae8d5344b7fc6aff759fce80a3ab7ba7f61a7d912adc1dab3c147077cd4fd79c9
DIST botocore-1.29.37.gh.tar.gz 11077206 BLAKE2B 59c877edba074d4d5858dbf0a4026c0884cc4fce5bc2c9a7d933cfbff8317825663955205ebc754f8a4713b817b7d775fe208d6946f788a1943989949da58a04 SHA512 e79447fe66a506326c5f6396a32b5f4f6560038c57ab03457c36c838f52c1e48a94cba7624350a738eb937d0f3954984b77fd97ffb4becfa72cc4c61005efd40
DIST botocore-1.29.38.gh.tar.gz 11079677 BLAKE2B 3edca40f575278b24c4b65ccaba3432715f8d7908f6e561cc475963f0865ef777a53845a1e8579f023a4943d69f33c8e1071afa6dd214d480dd48bacc8c132e1 SHA512 814863a6653f36f58bb20d4c7e154ba6d731f4046f3183ce696f515b1baa5ce342620bdfdd09eeea3847c6494add5611651487ad4d8f9c773823cf20393cb940
+DIST botocore-1.29.39.gh.tar.gz 11079996 BLAKE2B 5354766665b3402861cd497ee2831cb82c7d6db977c6573cb43cd70ec06291a4eba6c39a601c798414c2fb47c92f14df6e302623c1d5a5523edfdd9c977bf579 SHA512 bf7c30313737792eea1506855aa166cac63fcba48b764ec5e5b2313c9c66fe48970cfeef1f7405f329db715ee0b9d49ff4550d6d69ccd4c7db09923e77bcbe8d
diff --git a/dev-python/botocore/botocore-1.29.39.ebuild b/dev-python/botocore/botocore-1.29.39.ebuild
new file mode 100644
index 000000000000..36f6e1eb862b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.39.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}