summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-08 08:20:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-08 08:21:23 +0200
commita3427e78a775b10e1acd8de308d80b61cce3eee6 (patch)
tree3a97ded2e131dc3cb86b0904ced44f51b41a06ab
parentdev-python/scrypt: Remove old (diff)
downloadgentoo-a3427e78.tar.gz
gentoo-a3427e78.tar.bz2
gentoo-a3427e78.zip
dev-python/pycurl: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pycurl/Manifest2
-rw-r--r--dev-python/pycurl/pycurl-7.43.0.6.ebuild88
-rw-r--r--dev-python/pycurl/pycurl-7.44.0.ebuild80
3 files changed, 0 insertions, 170 deletions
diff --git a/dev-python/pycurl/Manifest b/dev-python/pycurl/Manifest
index 026eed71879f..ee105912f34c 100644
--- a/dev-python/pycurl/Manifest
+++ b/dev-python/pycurl/Manifest
@@ -1,3 +1 @@
-DIST pycurl-7.43.0.6.tar.gz 222895 BLAKE2B 5a923a3d7a57aa553361206fd0c0e43e6ad66a70af72540c08a29903a9a71ed6b9460c06ab6e50fc2a01d1badd45edf41eb36f6dd97fca3c83bef30f12e41c40 SHA512 5625d9e38159fb785afaf539372a8ac658d9118fb25f581f11629859fde400b6fccf65e03a19e182534a78169531304639b1e6f1bfdd2cb09bce95d581b52850
-DIST pycurl-7.44.0.tar.gz 227443 BLAKE2B b0c19058f3df74702221d01320d6c2c389f67b41c1fa5728aba50266f4120d736d38e510ee20f66e163fad14957e8ec38c9cfcd217845b4a5c4d2253afaec175 SHA512 9e371796650cd698ec50236714cba203782d793154f8325c8b2f106d2ce9b1a60766d7641b84702ec32dc83fa6e3ffe16cb774cb9ccba9747cfb089d9caec8e6
DIST pycurl-7.44.1.tar.gz 227562 BLAKE2B 7dcbde563140f28382768b89b95422f873d5396a1f050dfcd3686d87b0ca2c3f3871281ed87b1dfbe7e4268728c2ec3ba7a76e7d7ef57754af5c185bf2a6fbe8 SHA512 e251db332791de07364695b5fd59b3a290486eabbde8be9914b5edeefa8702b4dd9ab678739ad765f76ededeb7192444fefe2a076d3977f454259dfd06731059
diff --git a/dev-python/pycurl/pycurl-7.43.0.6.ebuild b/dev-python/pycurl/pycurl-7.43.0.6.ebuild
deleted file mode 100644
index 7c6638790163..000000000000
--- a/dev-python/pycurl/pycurl-7.43.0.6.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-# The selftests fail with pypy, and urlgrabber segfaults for me.
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="python binding for curl/libcurl"
-HOMEPAGE="
- https://github.com/pycurl/pycurl
- https://pypi.org/project/pycurl/
- http://pycurl.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl examples ssl test"
-RESTRICT="!test? ( test )"
-
-# Depend on a curl with curl_ssl_* USE flags.
-# libcurl must not be using an ssl backend we do not support.
-# If the libcurl ssl backend changes pycurl should be recompiled.
-# If curl uses gnutls, depend on at least gnutls 2.11.0 so that pycurl
-# does not need to initialize gcrypt threading and we do not need to
-# explicitly link to libgcrypt.
-RDEPEND="
- >=net-misc/curl-7.25.0-r1:=[ssl=]
- ssl? (
- net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
- curl_ssl_gnutls? ( >=net-libs/gnutls-2.11.0:= )
- curl_ssl_openssl? ( dev-libs/openssl:= )
- )"
-
-# bottle-0.12.7: https://github.com/pycurl/pycurl/issues/180
-# bottle-0.12.7: https://github.com/defnull/bottle/commit/f35197e2a18de1672831a70a163fcfd38327a802
-DEPEND="${RDEPEND}
- test? (
- dev-python/bottle[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),http2]
- >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
- # disable automagic use of setuptools
- sed -e 's:import wheel:raise ImportError:' -i setup.py || die
- # these tests are broken with newer versions of bottle
- sed -e 's:test.*_invalid_utf8:_&:' -i tests/getinfo_test.py || die
- # these tests break with newer version of curl, because they rely
- # on specific error messages
- rm tests/failonerror_test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- # Override faulty detection in setup.py, bug 510974.
- export PYCURL_SSL_LIBRARY=${CURL_SSL}
-}
-
-src_test() {
- emake -C tests/fake-curl/libcurl CC="$(tc-getCC)"
-
- distutils-r1_src_test
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- nosetests -a '!standalone,!gssapi' -v --with-flaky || die "Tests fail with ${EPYTHON}"
- nosetests -a 'standalone' -v --with-flaky || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local HTML_DOCS=( doc/. )
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pycurl/pycurl-7.44.0.ebuild b/dev-python/pycurl/pycurl-7.44.0.ebuild
deleted file mode 100644
index 1355dca8d709..000000000000
--- a/dev-python/pycurl/pycurl-7.44.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="python binding for curl/libcurl"
-HOMEPAGE="
- https://github.com/pycurl/pycurl
- https://pypi.org/project/pycurl/
- http://pycurl.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl examples ssl test"
-RESTRICT="!test? ( test )"
-
-# Depend on a curl with curl_ssl_* USE flags.
-# libcurl must not be using an ssl backend we do not support.
-# If the libcurl ssl backend changes pycurl should be recompiled.
-# If curl uses gnutls, depend on at least gnutls 2.11.0 so that pycurl
-# does not need to initialize gcrypt threading and we do not need to
-# explicitly link to libgcrypt.
-RDEPEND="
- >=net-misc/curl-7.25.0-r1:=[ssl=]
- ssl? (
- net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
- curl_ssl_gnutls? ( >=net-libs/gnutls-2.11.0:= )
- curl_ssl_openssl? ( dev-libs/openssl:= )
- )"
-
-# bottle-0.12.7: https://github.com/pycurl/pycurl/issues/180
-# bottle-0.12.7: https://github.com/defnull/bottle/commit/f35197e2a18de1672831a70a163fcfd38327a802
-DEPEND="${RDEPEND}
- test? (
- dev-python/bottle[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),http2]
- >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # docs installed into the wrong directory
- sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
- # a cheap hack to make setuptools usage not depend on wheel
- # -- replace wheel with random standard module that is used anyway
- sed -e 's:wheel:sys:' -i setup.py || die
- # TODO
- sed -e 's:test_socks5_gssapi_nec_setopt:_&:' \
- -i tests/option_constants_test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- # Override faulty detection in setup.py, bug 510974.
- export PYCURL_SSL_LIBRARY=${CURL_SSL}
-}
-
-src_test() {
- emake -C tests/fake-curl/libcurl CC="$(tc-getCC)"
-
- distutils-r1_src_test
-}
-
-python_test() {
- nosetests -a '!standalone,!gssapi' -v --with-flaky || die "Tests fail with ${EPYTHON}"
- nosetests -a 'standalone' -v --with-flaky || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local HTML_DOCS=( doc/. )
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}