summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-05-20 21:19:55 +0200
committerPacho Ramos <pacho@gentoo.org>2022-05-20 21:30:24 +0200
commita34541c86c83849132706f7bfab58ba6d3a7460f (patch)
tree833bdbb7bc1838e1a1a57b3610789f3311b42864
parentmedia-gfx/qiv: Keyword 2.3.2-r1 arm64, #846497 (diff)
downloadgentoo-a34541c8.tar.gz
gentoo-a34541c8.tar.bz2
gentoo-a34541c8.zip
dev-libs/dotconf: Remove unneeded .la files
Closes: https://bugs.gentoo.org/593744 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--dev-libs/dotconf/dotconf-1.3-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/dotconf/dotconf-1.3-r2.ebuild b/dev-libs/dotconf/dotconf-1.3-r2.ebuild
new file mode 100644
index 000000000000..d2f6fc9815eb
--- /dev/null
+++ b/dev-libs/dotconf/dotconf-1.3-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="dot.conf configuration file parser"
+HOMEPAGE="https://github.com/williamh/dotconf"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=sys-devel/autoconf-2.58"
+RDEPEND=""
+
+src_configure() {
+ econf --disable-static
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}