summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-19 07:42:13 +0000
committerSam James <sam@gentoo.org>2021-10-19 07:43:58 +0000
commita3770605158f94fa53b5845aa264be0f0bdf0915 (patch)
tree3f74763ed48b76c4ac133eea0aebaa04534fd009
parentapp-antivirus/clamav: use REQUIRED_USE for tests (diff)
downloadgentoo-a3770605158f94fa53b5845aa264be0f0bdf0915.tar.gz
gentoo-a3770605158f94fa53b5845aa264be0f0bdf0915.tar.bz2
gentoo-a3770605158f94fa53b5845aa264be0f0bdf0915.zip
app-antivirus/clamav: use consistent style, misc tidying
CMAKE_ECLASS doesn't do anything for cmake.eclass (it does for cmake-multilib.eclass in <= EAPI 7 though). Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-antivirus/clamav/clamav-0.104.0-r1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/app-antivirus/clamav/clamav-0.104.0-r1.ebuild b/app-antivirus/clamav/clamav-0.104.0-r1.ebuild
index 9b3bb334bb9b..ee0e19b95004 100644
--- a/app-antivirus/clamav/clamav-0.104.0-r1.ebuild
+++ b/app-antivirus/clamav/clamav-0.104.0-r1.ebuild
@@ -3,7 +3,6 @@
EAPI=7
-CMAKE_ECLASS=cmake
inherit cmake flag-o-matic systemd tmpfiles
DESCRIPTION="Clam Anti-Virus Scanner"
@@ -13,7 +12,7 @@ SRC_URI="https://www.clamav.net/downloads/production/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE="doc clamonacc +clamapp libclamav-only milter rar selinux systemd test uclibc"
+IUSE="doc clamonacc +clamapp libclamav-only milter rar selinux systemd test"
REQUIRED_USE="libclamav-only? ( !clamonacc !clamapp !milter )
clamonacc? ( clamapp )
@@ -58,7 +57,7 @@ PATCHES=(
src_configure() {
use elibc_musl && append-ldflags -lfts
use ppc64 && append-flags -mminimal-toc
- use uclibc && export ac_cv_type_error_t=yes
+ use elibc_uclibc && export ac_cv_type_error_t=yes
local mycmakeargs=(
-DDATABASE_DIRECTORY="${EPREFIX}"/var/lib/clamav
@@ -98,7 +97,7 @@ src_install() {
rm -rf "${ED}"/var/lib/clamav || die
if ! use libclamav-only ; then
- if use systemd; then
+ if use systemd ; then
# The tmpfiles entry is behind USE=systemd because the
# upstream OpenRC service files should (and do) ensure that
# the directories they need exist and have the correct
@@ -113,7 +112,7 @@ src_install() {
"freshclamd.service"
fi
- if use clamapp; then
+ if use clamapp ; then
# Modify /etc/{clamd,freshclam}.conf to be usable out of the box
sed -e "s:^\(Example\):\# \1:" \
-e "s/^#\(PidFile .*\)/\1/" \
@@ -152,7 +151,7 @@ src_install() {
local i
for i in clamd freshclam clamav-milter
do
- if [[ -f "${ED}"/etc/"${i}".conf.sample ]]; then
+ if [[ -f "${ED}"/etc/"${i}".conf.sample ]] ; then
mv "${ED}"/etc/"${i}".conf{.sample,} || die
fi
done