summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-08-19 23:17:52 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-08-19 23:17:52 +0100
commita37f1f417bfb522bbfd76ee42f8364000af56a5f (patch)
tree4f6ec1fe44c4b6f77b09a0a14ee14fba8c4bca19
parentprofiles: Mask x11-themes/arc-theme[cinnamon] on applicable arches (diff)
downloadgentoo-a37f1f41.tar.gz
gentoo-a37f1f41.tar.bz2
gentoo-a37f1f41.zip
x11-themes/arc-theme: Version bump to 20200819
Closes: https://bugs.gentoo.org/733664 Package-Manager: Portage-3.0.3, Repoman-2.3.23 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--x11-themes/arc-theme/Manifest2
-rw-r--r--x11-themes/arc-theme/arc-theme-20200819.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/x11-themes/arc-theme/Manifest b/x11-themes/arc-theme/Manifest
index 079119201c9c..9410f5f3d469 100644
--- a/x11-themes/arc-theme/Manifest
+++ b/x11-themes/arc-theme/Manifest
@@ -2,3 +2,5 @@ DIST arc-theme-20190330-pngs.tar.xz 87632 BLAKE2B a860abe61d98c1ba2c7e13d21cb24e
DIST arc-theme-20190330.tar.xz 227936 BLAKE2B 35815019884c55ce2d22dbb2d78892c00b35839b017fb7f0c1e9e1f1bad1bf94703e0c15205045eed96add556381c28fdd702c7657226fd75492304abaafd41d SHA512 ac4f1bde028e027314004999502dcc914abf6070ffd4345021df486084de2c943e6c110776b3b6af55143962a40b368c060a11754ffaf30300b87cb923bc55b9
DIST arc-theme-20200502-pngs.tar.xz 88116 BLAKE2B 18dfee1f51a0e1e272f73523617600490584d9044539717d8a4712083d6cb87751449818b38d503bbc0a8ef016690d606a7f23ba253eda48aecfbadc0cb1b483 SHA512 c25df3088c6edcd88799200e33005b56bf048dff606a06678c8cc7af6d0d84eb9237fcc76b16057bbee538ffa01ae7e983ab94dd184b140ec45d12a8d06d3a1f
DIST arc-theme-20200502.tar.gz 1090296 BLAKE2B 10feeecee89007b6ae1aab2e7ad95f2f3513660e2d4dafccf659b0829047b0cb551b4d8e6923d409ededba2ec5ff9f6c93f0b2c3959e3a68d5e51ccbb76861d5 SHA512 95ebf8e434af1b5976ebef7489b9b5c51c919cd161cb6dc86056559f7b34c56a8d5580b74a30bf32dc1a32636f1c7633ab20ad204f6102d92509cf1e21032fcd
+DIST arc-theme-20200819-pngs.tar.xz 85156 BLAKE2B bdfab7230d3e932b77f7dce9c7258c371fc708e0b3947fd39a718aa91f792501b8c64b38856da7673115b800e5ef2913f220ce6b909311b5d3fdbf171526d56c SHA512 d6709ad91cf8ee309606331550e43febbe200f24c07548bd3bcff646a6237bd5365d60abed8deb55317d6fb419a71627f3f9510bb117799f6fa3dd012ade992c
+DIST arc-theme-20200819.tar.xz 238792 BLAKE2B 94f7b2f073518031c6b47f4b5b245a5c73205a859528346dde51fb1e51051617c57969d1ff2359563803360c0bc46fe368aff34a9cc606389fe6fa9e4f8d22ed SHA512 bedff15a195c21934a813ca600b88ced81c3db66b7c25ab75b7193998a89338a7888711abb213877210a62d2460300bc32d40402bdd1f6c4d8fa903999eb1b0e
diff --git a/x11-themes/arc-theme/arc-theme-20200819.ebuild b/x11-themes/arc-theme/arc-theme-20200819.ebuild
new file mode 100644
index 000000000000..b3a90da75f7e
--- /dev/null
+++ b/x11-themes/arc-theme/arc-theme-20200819.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# USE="-* gtk2 gtk3 xfce" ebuild ${P}.ebuild clean compile
+# cd ~portage/x11-themes/${P}/work
+# make -j -C */common/gtk-3.0/3.18
+# find */common/{gtk-2.0,gtk-3.0/3.*,xfwm4} -name "*.png" ! -path "*/menubar-toolbar/*" | xargs tar Jcvf /usr/portage/distfiles/${P}-pngs.tar.xz --owner=root --group=root
+
+inherit autotools
+
+DESCRIPTION="A flat theme with transparent elements for GTK+3, GTK+2 and GNOME Shell"
+HOMEPAGE="https://github.com/jnsh/arc-theme"
+SRC_URI="https://github.com/jnsh/${PN}/releases/download/${PV}/arc-theme-${PV}.tar.xz
+ pre-rendered? ( https://dev.gentoo.org/~chewi/distfiles/${P}-pngs.tar.xz )"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="cinnamon gnome-shell +gtk2 +gtk3 mate +pre-rendered xfce"
+
+SASSC_DEPEND="
+ dev-lang/sassc
+"
+
+SVG_DEPEND="
+ !pre-rendered? (
+ media-gfx/inkscape
+ media-gfx/optipng
+ )
+"
+
+# Supports various GTK+3 versions and uses pkg-config to determine which
+# set of files to install. Updates will break it but only this fix will
+# help. See https://github.com/horst3180/arc-theme/pull/436. The same
+# applies to GNOME Shell and Cinnamon but I don't know whether those are
+# fixable.
+BDEPEND="
+ cinnamon? (
+ ${SASSC_DEPEND}
+ gnome-extra/cinnamon
+ )
+ gnome-shell? (
+ ${SASSC_DEPEND}
+ >=gnome-base/gnome-shell-3.18
+ )
+ gtk2? (
+ ${SVG_DEPEND}
+ )
+ gtk3? (
+ ${SASSC_DEPEND}
+ ${SVG_DEPEND}
+ virtual/pkgconfig
+ >=x11-libs/gtk+-3.18:3
+ )
+ xfce? (
+ ${SVG_DEPEND}
+ )
+"
+
+# gnome-themes-standard is only needed by GTK+2 for the Adwaita
+# engine. This engine is built into GTK+3.
+RDEPEND="
+ gtk2? (
+ x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine
+ )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use pre-rendered &&
+ export INKSCAPE="${BROOT}"/bin/false OPTIPNG="${BROOT}"/bin/false
+
+ econf \
+ --disable-plank \
+ --disable-unity \
+ $(use_enable cinnamon) \
+ $(use_enable gtk2) \
+ $(use_enable gtk3) \
+ $(use_enable gnome-shell) \
+ $(use_enable mate metacity) \
+ $(use_enable xfce xfwm)
+}
+
+src_compile() {
+ # fontconfig issue?
+ # https://bugs.gentoo.org/666418#c28
+ use pre-rendered ||
+ addpredict "${BROOT}"/usr/share/inkscape/fonts/.uuid.TMP-XXXXXX
+
+ default
+}