summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-04 15:37:39 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-04 15:44:07 +0100
commita39b769ee31e899fe3938cb2d2002f0663b1eccd (patch)
tree9026c448be41222c214d2a52c235ffe7c81a5f2b
parentdev-python/pyproject-metadata: Remove old (diff)
downloadgentoo-a39b769e.tar.gz
gentoo-a39b769e.tar.bz2
gentoo-a39b769e.zip
dev-python/dulwich: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dulwich/Manifest3
-rw-r--r--dev-python/dulwich/dulwich-0.20.50.ebuild55
-rw-r--r--dev-python/dulwich/dulwich-0.21.0.ebuild55
-rw-r--r--dev-python/dulwich/dulwich-0.21.1.ebuild55
4 files changed, 0 insertions, 168 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 4ae7eb62fda9..e78409642661 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,5 +1,2 @@
-DIST dulwich-0.20.50.tar.gz 430389 BLAKE2B 1ea86fe00fa560311bdcff8c51904982a506fa670efb503f9103c5fb25036a792a87583fdf6435a6a6ec7bd6aaa2277c621359e1d99f55450c247fdc4be74e51 SHA512 506cc76f7deb8247b910fa4971e28eeda6ddd34703ac3c7a2f3b6525e6a9229bbec527b1965bebf7aa3da17b5adbd146916f247acacf9caf86d2494e60cc8626
-DIST dulwich-0.21.0.tar.gz 436570 BLAKE2B d63185fe6e900823f5b295454a41be4f8508aa4c1757599186a0daab6f9b44e0036485d16d9f3dd34e3d1d191987cb0191254cee844caadadf9e43d0a2de0645 SHA512 ff437cb8381d91183d2843397afed5c1b04db000a093d61b6cdb1d76821104260e9d8572a05cf10c8959b88b99ec8fbcd3ff3a3ae2f860ab6201773de32635b5
-DIST dulwich-0.21.1.tar.gz 436958 BLAKE2B b821eb8a195496066017c0f9c9076ed25e1bfb894cead5175143a8944a16b8a82ca54d9a65d1aea23d7a039ce63343c608e2694f756b65b49e345d0ff49293f4 SHA512 bef3725b6101d0b8f115df432ca41a5f7b05fc5d84aa87f99f5815c670775ab74264a88768fbbe41bb89ff4cc6618b5a8a01ad2dae33f121ead424b5ed977f82
DIST dulwich-0.21.2.tar.gz 436949 BLAKE2B 8c3b42e103146c3641292eaaae29b2e53690a84fe0ba68adcaecc7ed75ce5ee3af64cffcc702b98a5bef18b6edfe888b2db0232430cf0289d1ca14dd49f3fb14 SHA512 edc7ea98f3417bd3f460d3c5fb54ceb1974df79e85fea4b4d324a79f487a5303edbdb256bae0b5c6e83615cf8788a2a921bfbd5031d4d3e4dbdd1c97ea1295e8
DIST dulwich-0.21.3.tar.gz 437815 BLAKE2B 889bb20800bbf45da6ddd688ed1e8ff2ca76fc3671409bb4bee4ed7604f008610adcd68feda9bf50bdd6432d3ad400e381506369d6411905a8388884093d5540 SHA512 ffe89535bd48709e68bff6b299034ab6ccd28960cc32b3717d9779c84c87548d8366dfadfb0699c99b99f8e599d91284e05dcc3c1f9ae4d7b208500856eb33ac
diff --git a/dev-python/dulwich/dulwich-0.20.50.ebuild b/dev-python/dulwich/dulwich-0.20.50.ebuild
deleted file mode 100644
index d774e8bcb728..000000000000
--- a/dev-python/dulwich/dulwich-0.20.50.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
-HOMEPAGE="
- https://github.com/jelmer/dulwich/
- https://pypi.org/project/dulwich/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+ Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ~ppc64 ~riscv ~s390 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- app-crypt/gpgme[python,${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/fastimport[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-
-python_test() {
- # remove interference from the tests that do stuff like user.name
- unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
- GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
- # Do not use make check which rebuilds the extension and uses -Werror,
- # causing unexpected failures.
- "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
- die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/dulwich/dulwich-0.21.0.ebuild b/dev-python/dulwich/dulwich-0.21.0.ebuild
deleted file mode 100644
index 2949d3dcec07..000000000000
--- a/dev-python/dulwich/dulwich-0.21.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
-HOMEPAGE="
- https://github.com/jelmer/dulwich/
- https://pypi.org/project/dulwich/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+ Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- app-crypt/gpgme[python,${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/fastimport[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-
-python_test() {
- # remove interference from the tests that do stuff like user.name
- unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
- GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
- # Do not use make check which rebuilds the extension and uses -Werror,
- # causing unexpected failures.
- "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
- die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/dulwich/dulwich-0.21.1.ebuild b/dev-python/dulwich/dulwich-0.21.1.ebuild
deleted file mode 100644
index 2949d3dcec07..000000000000
--- a/dev-python/dulwich/dulwich-0.21.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
-HOMEPAGE="
- https://github.com/jelmer/dulwich/
- https://pypi.org/project/dulwich/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+ Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- app-crypt/gpgme[python,${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/fastimport[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-
-python_test() {
- # remove interference from the tests that do stuff like user.name
- unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
- GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
- # Do not use make check which rebuilds the extension and uses -Werror,
- # causing unexpected failures.
- "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
- die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
- distutils-r1_python_install_all
-}