summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-11 06:27:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-11 06:57:53 +0200
commita3a158b182ab647b29c6ae65b8ae3654488b38b0 (patch)
tree079876850d3c605821b3d45ba50db38725e31309
parentapp-admin/awscli: Bump to 1.32.103 (diff)
downloadgentoo-a3a158b182ab647b29c6ae65b8ae3654488b38b0.tar.gz
gentoo-a3a158b182ab647b29c6ae65b8ae3654488b38b0.tar.bz2
gentoo-a3a158b182ab647b29c6ae65b8ae3654488b38b0.zip
dev-python/hypothesis: Bump to 6.100.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.100.6.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index e4b3b168e0d0..dbc0c2b18bd5 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-6.100.1.gh.tar.gz 9450717 BLAKE2B b27e3be6b43ee7d140ee00064748cd
DIST hypothesis-6.100.2.gh.tar.gz 9452773 BLAKE2B 46519695d9fdefeeb3c24abacfb0dd495003c21e02b154a5873f1a0ec1f9ba04998398fd7a29c570b15f2fcce95e5ca9451687c37aae2e2b27190534480f8c4e SHA512 ba4cbc3ee7cb958e32c59cfba095eafe8108f5a614316bf490105939e7c487bd56890794aa5d9583feeb4a0b7852a966da16f7e4fac1721f55eb105d03637cbe
DIST hypothesis-6.100.4.gh.tar.gz 9453201 BLAKE2B 0df377ae666646748fd15f70e296edab92587e0aa2deeb026950dff5e440c1d52d89a48245ba43044061b85ec0a009a8b88500b5e39513a8d0bce9afcc16dafa SHA512 089d8975ccfc8c13d092ddc67003d20ffe181950343b7bddd80769c7a55211cd073c4a0b29f5b46d2be6dc849263d79114e141becf732cdc895addeb2e535c5a
DIST hypothesis-6.100.5.gh.tar.gz 9453477 BLAKE2B 8b0ea09b30002a07f91ad8ac59c71b3aece27739c1c3d7a1cf4806dbd7d0cb280277937e0c4f88f64dfc97991753e6c7185ffa5c414c4ba061b87d68a3ca5bd2 SHA512 183aa4ef3425b2bbc632ad77c2ce4b7b7137a81b8344607082e5993593fbc820c68944c1a30c826c655d55145251dc5d53193eb444ce28fce930404ce33621c6
+DIST hypothesis-6.100.6.gh.tar.gz 9456232 BLAKE2B 348f1ccbd4947ac6811eefd7ba997c25e19db79a19ab042ce913490f96a0edc063297ffcb91edffac7788cf5889a1b3360d59f31bf3bc8a8ef9f974a0cbb8793 SHA512 1f09f8ec1095b00317ec390c5755c2e0f469a5dc712d1f52053a384dc913172adda8fd1f424353aa9b0de5cec537f5822f2e29031db0bc83fd19ba74df44ec3c
diff --git a/dev-python/hypothesis/hypothesis-6.100.6.ebuild b/dev-python/hypothesis/hypothesis-6.100.6.ebuild
new file mode 100644
index 000000000000..c2bf166b155f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.100.6.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 python3_13 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}