summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-18 23:34:10 +0000
committerSam James <sam@gentoo.org>2021-05-18 23:35:15 +0000
commita3d5c325c790fb1072489d4f3e29665b3ef58d61 (patch)
tree41f2ced78111e1566d5c8b21d81a508c7d650f70
parentdev-python/typed-ast: Stabilize 1.4.3 ppc64, #790962 (diff)
downloadgentoo-a3d5c325c790fb1072489d4f3e29665b3ef58d61.tar.gz
gentoo-a3d5c325c790fb1072489d4f3e29665b3ef58d61.tar.bz2
gentoo-a3d5c325c790fb1072489d4f3e29665b3ef58d61.zip
app-editors/ne: add 3.3.1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/ne/Manifest1
-rw-r--r--app-editors/ne/files/ne-3.3.1-respect-CFLAGS.patch14
-rw-r--r--app-editors/ne/ne-3.3.1.ebuild57
3 files changed, 72 insertions, 0 deletions
diff --git a/app-editors/ne/Manifest b/app-editors/ne/Manifest
index b558bdc9e67b..f8c4a374195d 100644
--- a/app-editors/ne/Manifest
+++ b/app-editors/ne/Manifest
@@ -1 +1,2 @@
DIST ne-3.3.0.tar.gz 1173159 BLAKE2B a4be3fd37a0a79b440290846184bc50551cfb9b73dc50c0376110f3603233879b396f67a87e2f9defe9c0cbc42c963e66bc43ab5396f8ccb27e5b6182c429006 SHA512 73a1bbc5a9f62354834288e25b8f4bf2b0d2ff6faf3408108b217305e2c9d8fed768b5a3c3fd21df7b3bf75a3f9c71ea899a8b3f528b560a8e5e66accd442919
+DIST ne-3.3.1.tar.gz 1138072 BLAKE2B 8494ff955b456bbac2e82823ee155980f8fab5a1071d0bfd6a987f1ed0724129ab2ecb70737547836b592369b45daf5e499d50d7230b04c5eabfd1536a56271f SHA512 d8c1d8cd9bbafcc7c8c485ca4454d6979be3d33ae918139865ce5f76e428f165043707c95c2e440bd9bccd00c67ce81a41f87f94b85cae3518c4749233718123
diff --git a/app-editors/ne/files/ne-3.3.1-respect-CFLAGS.patch b/app-editors/ne/files/ne-3.3.1-respect-CFLAGS.patch
new file mode 100644
index 000000000000..13e47b9be2b1
--- /dev/null
+++ b/app-editors/ne/files/ne-3.3.1-respect-CFLAGS.patch
@@ -0,0 +1,14 @@
+diff --git a/src/makefile b/src/makefile
+index ae358fe..76bfe1d 100644
+--- a/src/makefile
++++ b/src/makefile
+@@ -96,8 +96,7 @@ endif
+
+ # Test for GCC
+ ifneq (,$(findstring gcc,$(shell $(CC) 2>&1)))
+-GCCFLAGS=-std=c99 -Wall -Wno-parentheses -fno-strict-aliasing -flto=auto -ffat-lto-objects -Wp,-D_FORTIFY_SOURCE=2
+-LDFLAGS=-flto=auto
++GCCFLAGS=-std=c99 -Wall -Wno-parentheses -fno-strict-aliasing -Wp,-D_FORTIFY_SOURCE=2
+ endif
+
+ CFLAGS=$(GCCFLAGS) \
diff --git a/app-editors/ne/ne-3.3.1.ebuild b/app-editors/ne/ne-3.3.1.ebuild
new file mode 100644
index 000000000000..242892b33de8
--- /dev/null
+++ b/app-editors/ne/ne-3.3.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="The nice editor, easy to use for the beginner and powerful for the wizard"
+HOMEPAGE="https://ne.di.unimi.it/"
+SRC_URI="https://ne.di.unimi.it/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="sys-libs/ncurses:="
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+
+HTML_DOCS=( doc/html/. )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3.1-respect-CFLAGS.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's/-O3//' src/makefile || die
+}
+
+src_configure() {
+ # bug #776799
+ sed -i -e "s/-lcurses/$($(tc-getPKG_CONFIG) --libs ncurses)/" src/makefile || die
+}
+
+src_compile() {
+ append-cflags -std=c11
+ emake -C src CC="$(tc-getCC)" \
+ NE_GLOBAL_DIR="/usr/share/${PN}" \
+ OPTS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ "${PN}"
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /usr/share/${PN}/syntax
+ doins syntax/*.jsf
+
+ doman doc/${PN}.1
+ dodoc CHANGES README.md NEWS doc/*.{txt,pdf,texinfo} doc/default.*
+}