summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-17 16:29:28 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-17 16:32:33 +0200
commita3ddee3a0c95e932481d494930a05f6f34938c1e (patch)
treea54575eea776078c57c65333363f97da5f2f31ef
parentmedia-libs/libsdl2: sparc stable wrt bug #736186 (diff)
downloadgentoo-a3ddee3a.tar.gz
gentoo-a3ddee3a.tar.bz2
gentoo-a3ddee3a.zip
net-misc/openssh: depend on >=sys-kernel/linux-headers-5.1
In >=sys-libs/glibc-2.31 we are already forcing an upgrade of net-misc/openssh. However, sandbox code in OpenSSH [Link 1] is guarded by "#ifdef" so an upgrade of OpenSSH before glibc upgrade won't fix the problem if system is using old linux-headers without __NR_clock_nanosleep{,_time64}. Forcing >=linux-headers-5.1 will ensure that OpenSSH's sandbox supports __NR_clock_nanosleep{,_time64} and will therefore work with >=glibc-2.31. Link 1: https://github.com/openssh/openssh-portable/blob/V_8_3/sandbox-seccomp-filter.c#L252-L257 Bug: https://bugs.gentoo.org/708224 Closes: https://bugs.gentoo.org/737604 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--net-misc/openssh/openssh-8.1_p1-r4.ebuild (renamed from net-misc/openssh/openssh-8.1_p1-r3.ebuild)3
-rw-r--r--net-misc/openssh/openssh-8.2_p1-r7.ebuild (renamed from net-misc/openssh/openssh-8.2_p1-r6.ebuild)3
-rw-r--r--net-misc/openssh/openssh-8.3_p1-r5.ebuild (renamed from net-misc/openssh/openssh-8.3_p1-r4.ebuild)3
3 files changed, 6 insertions, 3 deletions
diff --git a/net-misc/openssh/openssh-8.1_p1-r3.ebuild b/net-misc/openssh/openssh-8.1_p1-r4.ebuild
index 75b805da4ddb..53ccdd567a28 100644
--- a/net-misc/openssh/openssh-8.1_p1-r3.ebuild
+++ b/net-misc/openssh/openssh-8.1_p1-r4.ebuild
@@ -82,8 +82,9 @@ RDEPEND="
kerberos? ( virtual/krb5 )
"
DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )
virtual/os-headers
+ kernel_linux? ( >=sys-kernel/linux-headers-5.1 )
+ static? ( ${LIB_DEPEND} )
"
RDEPEND="${RDEPEND}
pam? ( >=sys-auth/pambase-20081028 )
diff --git a/net-misc/openssh/openssh-8.2_p1-r6.ebuild b/net-misc/openssh/openssh-8.2_p1-r7.ebuild
index c0ed8f5dec46..c8fff3ba9509 100644
--- a/net-misc/openssh/openssh-8.2_p1-r6.ebuild
+++ b/net-misc/openssh/openssh-8.2_p1-r7.ebuild
@@ -81,8 +81,9 @@ RDEPEND="
kerberos? ( virtual/krb5 )
"
DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )
virtual/os-headers
+ kernel_linux? ( >=sys-kernel/linux-headers-5.1 )
+ static? ( ${LIB_DEPEND} )
"
RDEPEND="${RDEPEND}
pam? ( >=sys-auth/pambase-20081028 )
diff --git a/net-misc/openssh/openssh-8.3_p1-r4.ebuild b/net-misc/openssh/openssh-8.3_p1-r5.ebuild
index 6e93d57cf890..86300b9d8105 100644
--- a/net-misc/openssh/openssh-8.3_p1-r4.ebuild
+++ b/net-misc/openssh/openssh-8.3_p1-r5.ebuild
@@ -84,8 +84,9 @@ RDEPEND="
kerberos? ( virtual/krb5 )
"
DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )
virtual/os-headers
+ kernel_linux? ( >=sys-kernel/linux-headers-5.1 )
+ static? ( ${LIB_DEPEND} )
"
RDEPEND="${RDEPEND}
pam? ( >=sys-auth/pambase-20081028 )