summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergiy Borodych <Sergiy.Borodych@gmail.com>2016-07-11 15:22:05 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-07-14 18:05:22 +0200
commita3e207a8df7f215394fe28684e872f8f906df13d (patch)
tree79873ae48ce4ab1389fb35ab01259cbe2c44294d
parentdev-python/libzilla: Clean up old. (diff)
downloadgentoo-a3e207a8df7f215394fe28684e872f8f906df13d.tar.gz
gentoo-a3e207a8df7f215394fe28684e872f8f906df13d.tar.bz2
gentoo-a3e207a8df7f215394fe28684e872f8f906df13d.zip
app-portage/g-cpan: version bump to 0.16.9.
* Use github tag generated archive instead of uploaded release file. * Trim away extraneous tabs. Closes: https://github.com/gentoo/gentoo/pull/1872 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--app-portage/g-cpan/Manifest1
-rw-r--r--app-portage/g-cpan/g-cpan-0.16.9.ebuild55
-rw-r--r--app-portage/g-cpan/g-cpan-9999.ebuild12
3 files changed, 62 insertions, 6 deletions
diff --git a/app-portage/g-cpan/Manifest b/app-portage/g-cpan/Manifest
index d19ca60ca37e..5debb086eb2a 100644
--- a/app-portage/g-cpan/Manifest
+++ b/app-portage/g-cpan/Manifest
@@ -1,3 +1,4 @@
DIST g-cpan-0.16.5.tar.gz 33894 SHA256 929c06ee2cdd3361121b6f359ea7fc9201bc42caff96ef1df45b4cb93ccfd988 SHA512 f2eab23281abe567ee2df42895e3f0783228c6ab5e3a8230089e900fd2700367d736299da20fb228f2d4542491a24da05fd035a81aff7d79ce5132e35c48ad0b WHIRLPOOL 01e0b9fc59264455d57fc64c432e683ae941c74d6efa6e2b3430dea6caac019cfad3e893a4b39de4386a3dadadecf95d828a9fbaa8e8b1260303081e2cc6ce65
DIST g-cpan-0.16.6.tar.gz 33844 SHA256 efd0a99483d8ce4a6c828f145592846e6076887b33f95431d7b8256c6973906d SHA512 f8e9e211ffc09ca42d1444a42ad2b8111beb8988e4a01387cf8788f7e4a52e6133168820c2800ac82429fa022e2ff473a774c48ac140b5cde184b3d77cd6e1b1 WHIRLPOOL 95d7db1905df41f320b8876a02f53e3238d55ab1be30e4b086ed362797819629997edd06e167c21325cc8d13540247a842cedcfcf1a236737fec91835b952252
DIST g-cpan-0.16.7.tar.gz 33621 SHA256 35ead4120bee1b4158413eb1f5933baf1ce75500495d590163fbfef95c9c171f SHA512 2412b30fa4c3432882db0f31da6ace841e353a363e15a3b536ea1febcf601a7f9c4e14968e3abcf848e3557098088012472179688caf36cd97ae9b528a3db7fb WHIRLPOOL 646f76745023ae815ebecf57856b50dcd568657df68aee89099dd64904a4d43e9cef82f4f16518bd0b8db50e3ddd57aa200bf8fcffbd6539305f59be798bece1
+DIST g-cpan-0.16.9.tar.gz 34463 SHA256 2d85b37905af8d2878b949438d61d80d530184605260a3b49901b113ef8b7b42 SHA512 f26d81974fedb024808fe3671ae297fd36abc37a5b04783f36f6c9e8c6000a411c675e999e91da48801a7c84fde15a59587df02fa9d7b3833ccc0916993b1783 WHIRLPOOL a7f11aa4588fc5fe31ba9570b059b7f90a370f477e04ea62cd823c438f3ab27687417014fa62381b744f461825be4d3c9aff6d37f6880abf60a8f4cef41edf62
diff --git a/app-portage/g-cpan/g-cpan-0.16.9.ebuild b/app-portage/g-cpan/g-cpan-0.16.9.ebuild
new file mode 100644
index 000000000000..6b8aad9ad918
--- /dev/null
+++ b/app-portage/g-cpan/g-cpan-0.16.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit perl-module
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/gentoo-perl/g-cpan.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/gentoo-perl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="Autogenerate and install ebuilds for CPAN modules"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl/g-cpan"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+IUSE="test"
+
+COMMONDEPEND="
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ dev-perl/Log-Agent
+ virtual/perl-Memoize
+ virtual/perl-IO
+ dev-perl/Shell-EnvImporter
+ virtual/perl-Term-ANSIColor
+ >=dev-perl/YAML-0.60
+"
+RDEPEND="${COMMONDEPEND}
+ >=sys-apps/portage-2.0.0
+"
+DEPEND="${COMMONDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+src_install() {
+ perl-module_src_install
+ diropts -m0775 -o portage -g portage
+ dodir "/var/tmp/g-cpan"
+ dodir "/var/log/g-cpan"
+ keepdir "/var/log/g-cpan"
+}
+
+pkg_postinst() {
+ elog "If you want to use g-cpan as non root user you may wish to adjust"
+ elog "the permissions on /var/tmp/g-cpan or add users to the portage group."
+ elog "Please note that some CPAN packages need additional manual"
+ elog "parameters or tweaking, due to bugs in their build systems."
+}
diff --git a/app-portage/g-cpan/g-cpan-9999.ebuild b/app-portage/g-cpan/g-cpan-9999.ebuild
index a547d863bb0e..6b8aad9ad918 100644
--- a/app-portage/g-cpan/g-cpan-9999.ebuild
+++ b/app-portage/g-cpan/g-cpan-9999.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
SRC_URI=""
else
- SRC_URI="https://github.com/gentoo-perl/g-cpan/releases/download/v${PV}/${P}.tar.gz"
+ SRC_URI="https://github.com/gentoo-perl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
@@ -40,11 +40,11 @@ DEPEND="${COMMONDEPEND}
"
src_install() {
- perl-module_src_install
- diropts -m0775 -o portage -g portage
- dodir "/var/tmp/g-cpan"
- dodir "/var/log/g-cpan"
- keepdir "/var/log/g-cpan"
+ perl-module_src_install
+ diropts -m0775 -o portage -g portage
+ dodir "/var/tmp/g-cpan"
+ dodir "/var/log/g-cpan"
+ keepdir "/var/log/g-cpan"
}
pkg_postinst() {