summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-07-30 21:35:47 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-07-30 21:35:47 +0200
commita3f2844eb9e8bf89002f5f0843cb5894db9b96bb (patch)
treec046b94c287a2d9efc3365cd1e922e1d74f090aa
parentdev-python/nuitka: add 1.0 (diff)
downloadgentoo-a3f2844e.tar.gz
gentoo-a3f2844e.tar.bz2
gentoo-a3f2844e.zip
dev-python/django-crispy-forms: add to tree
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-python/django-crispy-forms/Manifest1
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild21
-rw-r--r--dev-python/django-crispy-forms/metadata.xml12
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/django-crispy-forms/Manifest b/dev-python/django-crispy-forms/Manifest
new file mode 100644
index 000000000000..fbc0996d9583
--- /dev/null
+++ b/dev-python/django-crispy-forms/Manifest
@@ -0,0 +1 @@
+DIST django-crispy-forms-1.14.0.tar.gz 295826 BLAKE2B 4be78ba2eb8b7dfd6d9813d2a94b26ca571f3c8767f22e37e64deca517b0044d1684343f82790860f024b6eaf6759acfdb6975e4497e40bb75cc64ace3ce9745 SHA512 964ebcd74dd284d11cd0a820238468cce415a61b9ac83afe401b1414da0e27b3e9e0a9aa4fec411a8ff9fa08aa6fb56550c6262e0a9d821b17e12590fc06970c
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild
new file mode 100644
index 000000000000..32f8a0f85bcb
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="DRY Django forms"
+HOMEPAGE="https://github.com/django-crispy-forms/django-crispy-forms"
+SRC_URI="https://github.com/django-crispy-forms/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" #Not working
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-crispy-forms/metadata.xml b/dev-python/django-crispy-forms/metadata.xml
new file mode 100644
index 000000000000..0e3ee306f637
--- /dev/null
+++ b/dev-python/django-crispy-forms/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-crispy-forms</remote-id>
+ <remote-id type="github">django-crispy-forms/django-crispy-forms</remote-id>
+ </upstream>
+</pkgmetadata>