summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-15 08:48:05 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-15 17:11:35 +0100
commita4145529da8607c9997a37bb0a0e7521856ccfc3 (patch)
tree92ac92316fbbb436fb4baced27bfa4a80e3e4305
parentdev-python/lazy-object-proxy: Bump to 1.7.0 (diff)
downloadgentoo-a4145529da8607c9997a37bb0a0e7521856ccfc3.tar.gz
gentoo-a4145529da8607c9997a37bb0a0e7521856ccfc3.tar.bz2
gentoo-a4145529da8607c9997a37bb0a0e7521856ccfc3.zip
dev-python/natsort: Bump to 8.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/natsort/Manifest1
-rw-r--r--dev-python/natsort/natsort-8.0.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/natsort/Manifest b/dev-python/natsort/Manifest
index f4900a5191cb..79284d00367f 100644
--- a/dev-python/natsort/Manifest
+++ b/dev-python/natsort/Manifest
@@ -1,2 +1,3 @@
DIST natsort-7.2.0.tar.gz 144338 BLAKE2B cba2a547813b56c3f42a6d9526be59ebda0e12f964ce72e166dec825ceab923b06f7be768e4071f9380e7b8c2a2d24a5b9af0ad0752e48655046bca44fd03ab9 SHA512 9490d4f3f304834a82f91fc7f215a9212e5e4a2c78e2d0943d886cff2f50c581171bd27edc8ceec23981ebaf8d13d3be2bf1954439dd76aef9a2cc9983b1968a
DIST natsort-8.0.1.tar.gz 144778 BLAKE2B 81aaeebb02b0a0e45d9291c4efd341eadff7be9e8b50a966e21b0a22b92eb05cee99148f6e2b93ce792bda2a223f1a64e43d2569dd1cbc4b421e11f2652722f8 SHA512 a1db383c466b8605006d880cb19f284902ae7384bca839877cc7baa0d60b5ab369126ae7efe0b93e1b5a0c399ad902fdd818beed2c34bb209b56e3c960896d4f
+DIST natsort-8.0.2.tar.gz 144912 BLAKE2B 0e5d83e6991ef1208b84cbf17e287f487a2a059d68274876977ae6f18f89492284bc166499a9518bfc2df19999e5593f386ce88beca94c23d8a050697c0b2a36 SHA512 fad31e1af1e1d4a33061b8b3e31d022f353f662d306136d05e0121a0531f33cf388467a40f91f51036f283ab8fbdefc1193d09f440052960ffdf733186b5fb27
diff --git a/dev-python/natsort/natsort-8.0.2.ebuild b/dev-python/natsort/natsort-8.0.2.ebuild
new file mode 100644
index 000000000000..2e369a39667d
--- /dev/null
+++ b/dev-python/natsort/natsort-8.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Natural sorting for Python"
+HOMEPAGE="https://pypi.org/project/natsort/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "sorting results that match most file browsers" "dev-python/pyicu"
+}