summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-02-24 22:08:57 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-02-24 22:47:31 +0100
commita41758ecc0c4dba5cfa14af8ed911a374ef67627 (patch)
tree82a4cca68bd383122d21a4b8e72b33cc5ac489f3
parentgnome-base/gnome-settings-daemon: fix USE="input_devices_wacom -wayland" build (diff)
downloadgentoo-a41758ec.tar.gz
gentoo-a41758ec.tar.bz2
gentoo-a41758ec.zip
x11-plugins/wmtimer: fix build with -fno-common
Closes: https://bugs.gentoo.org/709506 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-plugins/wmtimer/files/wmtimer-2.92-gcc-10.patch23
-rw-r--r--x11-plugins/wmtimer/wmtimer-2.92-r2.ebuild3
2 files changed, 25 insertions, 1 deletions
diff --git a/x11-plugins/wmtimer/files/wmtimer-2.92-gcc-10.patch b/x11-plugins/wmtimer/files/wmtimer-2.92-gcc-10.patch
new file mode 100644
index 000000000000..4332e8916640
--- /dev/null
+++ b/x11-plugins/wmtimer/files/wmtimer-2.92-gcc-10.patch
@@ -0,0 +1,23 @@
+diff -Naur wmtimer-2.92.orig/wmgeneral/wmgeneral.c wmtimer-2.92/wmgeneral/wmgeneral.c
+--- wmtimer-2.92.orig/wmgeneral/wmgeneral.c 2004-01-29 03:38:58.000000000 +0100
++++ wmtimer-2.92/wmgeneral/wmgeneral.c 2020-02-24 22:07:07.028810885 +0100
+@@ -67,6 +67,7 @@
+ GC NormalGC;
+ XpmIcon wmgen;
+ Pixmap pixmask;
++Display *display;
+
+ char *textColor = NULL;
+ XpmColorSymbol colorSymbols[3] = { {"Text", NULL, 0} };
+diff -Naur wmtimer-2.92.orig/wmgeneral/wmgeneral.h wmtimer-2.92/wmgeneral/wmgeneral.h
+--- wmtimer-2.92.orig/wmgeneral/wmgeneral.h 2001-10-11 07:38:39.000000000 +0200
++++ wmtimer-2.92/wmgeneral/wmgeneral.h 2020-02-24 22:06:49.756805063 +0100
+@@ -40,7 +40,7 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-plugins/wmtimer/wmtimer-2.92-r2.ebuild b/x11-plugins/wmtimer/wmtimer-2.92-r2.ebuild
index 361f2745af0f..f3fb9ab0ea23 100644
--- a/x11-plugins/wmtimer/wmtimer-2.92-r2.ebuild
+++ b/x11-plugins/wmtimer/wmtimer-2.92-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,6 +32,7 @@ src_prepare() {
cd "${WORKDIR}"/${P} || die
eapply "${FILESDIR}"/${P}-counter-fix.patch
eapply "${FILESDIR}"/${P}-list.patch
+ eapply "${FILESDIR}"/${P}-gcc-10.patch
eapply_user
}