summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-10 08:05:14 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-10 08:38:20 +0300
commita42f828baaac0b47a0083aeaced003daa40012b4 (patch)
tree54f50064c485aab5e0baafb5781bdc1d92019c01
parentdev-python/boto3: add 1.24.70 (diff)
downloadgentoo-a42f828b.tar.gz
gentoo-a42f828b.tar.bz2
gentoo-a42f828b.zip
app-admin/awscli: add 1.25.71
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.71.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 2ac1f733d8df..b8cd1b15e488 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.25.65.gh.tar.gz 2263933 BLAKE2B 5c516e6a95a333073cf7200eff476e625
DIST aws-cli-1.25.66.gh.tar.gz 2264111 BLAKE2B 7aaa42d654a873fea44fe64e0805c240700830c653ecfbfab4bf8838ba2aca5ec9508241e9fd9329b546d098eb4c68f886dac1afc31e12cea4779cc35ec091fb SHA512 dcddfebf2051fad23208c2617596c6aa4462e940056f5963526983c15b6c33bb118a769f139a8c8297d413e9a6ae129d7e14a6ffa56aa595dcde0128ea10d5c2
DIST aws-cli-1.25.67.gh.tar.gz 2264702 BLAKE2B 88bdeab8fe85d17d7aa78ff00125e1c3e1d098093d68b7e7213896d101bff443cb2ed23b8ed9245eb3727b41abd34a8047616eee777f802d52b3a26594e214c5 SHA512 a01b333d36160a43c1f28d01600e1f1d095e4713500bac3b13fc336bf790943251fefb72dc7bc177eaf4265b794658d62ff72ee00abd348c1265d04b58564136
DIST aws-cli-1.25.70.gh.tar.gz 2267239 BLAKE2B e20606c8b3df77698f6ad67eb28a63d8ddb5750782a5ca5a690d36bf5ec5d171aebda115a3c828fbae948037d71e11ead73e163fdaa55e81614ea245a51f54e5 SHA512 7984a56f4e224389822ebb6aa56927cc669630ba8fbebbb59178406ce1dcbb298ef0f83353c02ab37eaf4e0bfcd6b86363712d3f711540993044fa6517b84364
+DIST aws-cli-1.25.71.gh.tar.gz 2267936 BLAKE2B a44cc3995335d2556e919879127ebac77c274d6a1f55a390acb85d59d1ee3850826a9d0cc1b7d4e86cb7a5abf9ebac00a1a62aa0d0846a06c04166fa40b18abf SHA512 8c0f235a8f16404ca770ff8c157b52981bd808c25c045e39f7cca6b35d992caa921ac84f82309323b1b742ff783296a1d9ca51cb154704270940ce8a900c09b0
diff --git a/app-admin/awscli/awscli-1.25.71.ebuild b/app-admin/awscli/awscli-1.25.71.ebuild
new file mode 100644
index 000000000000..3d5bba5c1200
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.71.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# botocore is x.(y+2).(z-1)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 1 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}