summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-28 13:02:58 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-28 13:16:24 +0200
commita43ca85314a7748fb608e71b0e5b9b09f5818610 (patch)
tree1117386db0b65ac3a57cceacf1e6b23f29cea94a
parentdev-util/buildbot-grid-view: add 3.4.0, enable py3.10, cleanup (diff)
downloadgentoo-a43ca853.tar.gz
gentoo-a43ca853.tar.bz2
gentoo-a43ca853.zip
dev-util/buildbot-wsgi-dashboards: add 3.4.0, enable py3.10, cleanup
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest1
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.4.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index fd0cd1794836..994105b01040 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -7,3 +7,4 @@ DIST buildbot-wsgi-dashboards-3.1.0.tar.gz 5581 BLAKE2B 0ab769016aac877dbd2a802d
DIST buildbot-wsgi-dashboards-3.1.1.tar.gz 5583 BLAKE2B ba0462e70e29cc1e6cfcc6a461373bdc56c03dc0510e7498310e722e0a5c494311f6da081f1ccccd2641657a7025885211802ce38b13326bde2f0b2f403ee198 SHA512 3a4a4621ae2ecca9313d2c6c4c33566b3e2e58c0259caaf135935362139eb4c1536669251138408c76c136ffe4a93ba9cbca7fa08b7b07e46472b2606b24ab06
DIST buildbot-wsgi-dashboards-3.2.0.tar.gz 5582 BLAKE2B ad52295e4c334377372e0db03fdd0d6b929fe0c19184b02feb6ba6e296a11477e8334a1e23d3a8c720462064916fefc45f78e729e59bd3a789779711365df038 SHA512 9deba0ba64f5c57da5e4688538757ae287b9505d2e98dce0ba2e7a16fac80bceff666eadf9116739c3af5481749e1568c2b07c367ca33f7ac548cdc719535c75
DIST buildbot-wsgi-dashboards-3.3.0.tar.gz 5591 BLAKE2B 90ef8554d41a4a58f0ac320d688a95145a53bf7c56bed9a164940912d3d944f8e04668ef96aeeb862c6627d97b7a90e648a878710d8bf68a5c2dd4bc24436100 SHA512 bd791710f5788ff44be784549535c3043babea3c672c8e26f4563d1e5c5f217eff87b142ffbea3d94a6764cd2e5b422f48158cd70dfd8c1225ae299304903861
+DIST buildbot-wsgi-dashboards-3.4.0.tar.gz 5583 BLAKE2B 0eed4a375330d58bd6caf95f8cdc2ebfaebc9c123450461d4e0f938745bb1b6afe0e9786bd886c6e6cb6a522da2b645bf1ad3237b2049f86bc1bca83829b15a1 SHA512 56411bb34a1f40d02a814e8d33dcd3c6de65627728c3bb9cad776c43c48707e648ccdbb4a58cbfb8ed080c219fc37252304c88ab363eb6deb6057b2debde1071
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.4.0.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.4.0.ebuild
new file mode 100644
index 000000000000..89d8f635b8a7
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-wsgi-dashboards/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"