summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Genasci <fedeliallalinea@gmail.com>2018-10-08 09:21:10 +0200
committerVirgil Dupras <vdupras@gentoo.org>2018-10-18 07:55:38 -0400
commita44d0f0af67655eef4ba71aa789b3855c9339093 (patch)
tree38dd7cf80e996d3bf578c2ee8fd3ba39527c1082
parentsys-apps/hdparm-9.56-r0: alpha stable (diff)
downloadgentoo-a44d0f0a.tar.gz
gentoo-a44d0f0a.tar.bz2
gentoo-a44d0f0a.zip
app-emulation/genymotion-bin: version bump to 2.12.2
Closes: https://bugs.gentoo.org/655580 Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Marco Genasci <fedeliallalinea@gmail.com> Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
-rw-r--r--app-emulation/genymotion-bin/Manifest1
-rw-r--r--app-emulation/genymotion-bin/genymotion-bin-2.12.2.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/app-emulation/genymotion-bin/Manifest b/app-emulation/genymotion-bin/Manifest
index cda2f1ef6a1e..9a01451180fa 100644
--- a/app-emulation/genymotion-bin/Manifest
+++ b/app-emulation/genymotion-bin/Manifest
@@ -1 +1,2 @@
DIST genymotion-2.11.0-linux_x64.bin 45096365 BLAKE2B 8686e37a0e1bd0acf1847de40dfff650db6b723b65dc369652114c19fb51554ea9b1c1f11c8e8db568e44f50aaf043617ee263258d04e2e90e6c23bb41a0cf56 SHA512 b128fbe1e27120cdd88a6ac4661031231cc17fc0adf007fa986f7892571db7d8ce259bf6f106eb9e620149572d5ca242ae6032b7360ba7502b208ac18ef98e2e
+DIST genymotion-2.12.2-linux_x64.bin 45850812 BLAKE2B 74c3dfa73818f1d7318235d13acbff79d5dd27fd8d7c8cd246046406aaf8f2b9cdb9e9cb7c44bd294b0a047c2bd1e6a419bd4191dd3e332d82494f358cc9d73c SHA512 31b1c9de1a264f285938fcc62612a6aa74393e88f6075664f3e168c5226e74ab25e72061904716f6b2d33ed77221b8c4605c247090c7e2fd149ea8be96f9b5dc
diff --git a/app-emulation/genymotion-bin/genymotion-bin-2.12.2.ebuild b/app-emulation/genymotion-bin/genymotion-bin-2.12.2.ebuild
new file mode 100644
index 000000000000..b7acb03d4784
--- /dev/null
+++ b/app-emulation/genymotion-bin/genymotion-bin-2.12.2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils bash-completion-r1 pax-utils
+
+MY_PN="${PN/-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Complete set of tools that provide a virtual environment for Android"
+HOMEPAGE="https://genymotion.com"
+SRC_URI="${MY_P}-linux_x64.bin"
+DOWNLOAD_URL="https://www.genymotion.com/download/"
+
+LICENSE="genymotion"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+DEPEND=""
+RDEPEND="|| ( >=app-emulation/virtualbox-5.0.28 >=app-emulation/virtualbox-bin-5.0.28 )
+ app-arch/snappy
+ virtual/opengl
+ dev-libs/openssl
+ dev-libs/hiredis
+ media-gfx/graphite2
+ sys-apps/util-linux
+ media-libs/gst-plugins-base:0.10
+"
+# note if you compile protobuf with >=gcc-5.1 you need to disable the new c++11 abi
+# -D_GLIBCXX_USE_CXX11_ABI=0 to your CXXFLAGS for protobuf
+# =dev-libs/protobuf-2.6*
+
+RESTRICT="bindist fetch"
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo
+ einfo "Please visit ${DOWNLOAD_URL} and download ${A}"
+ einfo "which must be placed in DISTDIR directory."
+ einfo
+}
+
+src_unpack() {
+ cp "${DISTDIR}/${A}" "${WORKDIR}" || die "cp failed"
+}
+
+src_prepare() {
+ default
+
+ # removed function _install_desktop_file because happens outside of sandbox
+ sed -i -e "s/_install_desktop_file\ ||\ abort//" ${A} || die "sed failed"
+ chmod +x ${A} || die "chmod failed"
+ yes | ./${A} -d "${S}" > /dev/null || die "unpack failed"
+
+ # removed windows line for bashcompletion
+ sed -i -e "s/complete\ -F\ _gmtool\ gmtool.exe//" "${S}/${MY_PN}/completion/bash/gmtool.bash" || die "sed failed"
+}
+
+QA_PREBUILT="
+ opt/${MY_PN}/*.so*
+ opt/${MY_PN}/imageformats/*.so
+ opt/${MY_PN}/plugins/*.so*
+ opt/${MY_PN}/device-upgrade
+ opt/${MY_PN}/${MY_PN}
+ opt/${MY_PN}/genyshell
+ opt/${MY_PN}/player
+ opt/${MY_PN}/${MY_PN}adbtunneld
+ opt/${MY_PN}/gmtool
+"
+
+src_install() {
+ insinto /opt/"${MY_PN}"
+ doins -r "${MY_PN}"/{plugins,translations,icons}
+
+ doins -r "${MY_PN}"/{QtGraphicalEffects,QtQuick,QtQuick.2,platforms,sqldrivers,imageformats}
+ doins "${MY_PN}"/libQt*
+ doins "${MY_PN}"/qt.conf
+ doins "${MY_PN}"/libicu*
+
+ doins "${MY_PN}"/{libcom,librendering}.so*
+ # android library
+ doins "${MY_PN}"/{libEGL_translator,libGLES_CM_translator,libGLES_V2_translator,libOpenglRender}.so*
+
+ insopts -m0755
+ doins "${MY_PN}"/{device-upgrade,genymotion,genyshell,player,genymotionadbtunneld,gmtool}
+
+ pax-mark -m "${ED%/}/opt/${MY_PN}/${MY_PN}"
+ pax-mark -m "${ED%/}/opt/${MY_PN}/gmtool"
+
+ dosym "${ED%/}"/opt/"${MY_PN}"/genyshell /opt/bin/genyshell
+ dosym "${ED%/}"/opt/"${MY_PN}"/"${MY_PN}" /opt/bin/"${MY_PN}"
+ dosym "${ED%/}"/opt/"${MY_PN}"/gmtool /opt/bin/gmtool
+
+ newbashcomp "${MY_PN}/completion/bash/gmtool.bash" gmtool
+
+ if has_version "app-shells/zsh" ; then
+ insinto /usr/share/zsh/site-functions
+ doins "${MY_PN}/completion/zsh/_gmtool"
+ fi
+
+ make_desktop_entry "/opt/${MY_PN}/${MY_PN}" "Genymotion ${PV}" "/opt/${MY_PN}/icons/icon.png" "Development;Emulator;"
+ mv "${ED%/}"/usr/share/applications/*.desktop "${ED%/}"/usr/share/applications/"${MY_PN}".desktop || die "mv failed"
+}
+
+pkg_postinst() {
+ elog "Genymotion needs adb to work correctly: install with android-sdk-update-manager"
+ elog "'Android SDK Platform-tools' and 'Android SDK Tools'"
+ elog "Your user should also be in the android group to work correctly"
+ elog "Then in Genymotion set the android-sdk-update-manager directory: (Settings->ADB)"
+ elog
+ elog " /opt/android-sdk-update-manager"
+}