summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2022-05-29 22:21:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-06-23 12:16:55 +0300
commita463bb99d67e4588e96c58f9dd43e554f85bcc0c (patch)
treefaed525ef2f542a5c46d83d1b1de2f361f945244
parentdev-python/scipy: arm stable wrt bug #853388 (diff)
downloadgentoo-a463bb99.tar.gz
gentoo-a463bb99.tar.bz2
gentoo-a463bb99.zip
x11-wm/cwm: add 7.1
Add an ebuild for cwm-7.1. Closes: https://bugs.gentoo.org/847529 Signed-off-by: Philipp Rösner <rndxelement@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--x11-wm/cwm/Manifest1
-rw-r--r--x11-wm/cwm/cwm-7.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-wm/cwm/Manifest b/x11-wm/cwm/Manifest
index 400e19579f1e..0b8bf90e964c 100644
--- a/x11-wm/cwm/Manifest
+++ b/x11-wm/cwm/Manifest
@@ -1 +1,2 @@
DIST cwm-6.7.tar.gz 53172 BLAKE2B 9e8c6503235ee71f3974a4e64cf45b80675b6ff33a68505b07f003c8d711a68a158f31147f463d5467bb4242c6321ebe0acaee63727689a136ca83c47e7592ea SHA512 5ad0fa56d9c96c36cc32e68128e58d4e3a7483f349bb26be1083c5b5c6d853ff05eec1a783b07ed928bd99a35a2e0b2d7053fc89b828aa9bdfe3589a318c4171
+DIST cwm-7.1.tar.gz 53667 BLAKE2B 6d0b64e95b78201113eb75c537d3ffdc8bd1b2a1d50f88bf9f7126dbdef372e80f36c5c1fd84b5bee29c7e9da7debc479264af34cf8c48abf1358d3d0c046919 SHA512 aa14bc7a43a522f4b83d3f9a3b8a8344c339b52aac4733f410e388df56a2dc4e86ee1ae9f05b53ff3139808f87f38a4b2da57bf0525482613d46651e8f08c718
diff --git a/x11-wm/cwm/cwm-7.1.ebuild b/x11-wm/cwm/cwm-7.1.ebuild
new file mode 100644
index 000000000000..0697ed5e0269
--- /dev/null
+++ b/x11-wm/cwm/cwm-7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="https://github.com/leahneukirchen/cwm
+ https://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leahneukirchen/cwm.git"
+else
+ SRC_URI="https://github.com/leahneukirchen/cwm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+
+DEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc README
+ make_session_desktop ${PN} ${PN}
+}