summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-02-09 14:41:38 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-02-09 14:41:38 +0300
commita47bd35f59d9cd00947e037ed4c628bf08267802 (patch)
tree325e2ec71b924db3c1d471e3a9fbeef617de1299
parentsys-apps/cinit: port to EAPI=7 (diff)
downloadgentoo-a47bd35f.tar.gz
gentoo-a47bd35f.tar.bz2
gentoo-a47bd35f.zip
mail-client/hap: port to EAPI=7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--mail-client/hap/files/hap-3.7-ncurses.patch4
-rw-r--r--mail-client/hap/hap-3.7-r1.ebuild12
2 files changed, 8 insertions, 8 deletions
diff --git a/mail-client/hap/files/hap-3.7-ncurses.patch b/mail-client/hap/files/hap-3.7-ncurses.patch
index 1ae79b9e9810..3bd3efa3a1e4 100644
--- a/mail-client/hap/files/hap-3.7-ncurses.patch
+++ b/mail-client/hap/files/hap-3.7-ncurses.patch
@@ -1,5 +1,5 @@
---- configure.in 1996-07-17 00:50:03.000000000 +0300
-+++ configure.in 2013-03-06 15:09:29.579148360 +0200
+--- a/configure.in 1996-07-17 00:50:03.000000000 +0300
++++ b/configure.in 2013-03-06 15:09:29.579148360 +0200
@@ -6,8 +6,9 @@
AC_PROG_INSTALL
diff --git a/mail-client/hap/hap-3.7-r1.ebuild b/mail-client/hap/hap-3.7-r1.ebuild
index 54db510d8e8a..168f33fc748d 100644
--- a/mail-client/hap/hap-3.7-r1.ebuild
+++ b/mail-client/hap/hap-3.7-r1.ebuild
@@ -1,33 +1,33 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools eutils
+inherit autotools
DESCRIPTION="A terminal mail notification program (replacement for biff)"
HOMEPAGE="http://www.transbay.net/~enf/sw.html"
SRC_URI="http://www.transbay.net/~enf/${P}.tar"
-DEPEND="sys-libs/ncurses"
+DEPEND="sys-libs/ncurses:0="
RDEPEND="${DEPEND}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ppc x86"
-IUSE=""
S="${WORKDIR}/${PN}"
src_prepare() {
# Fix configure to use ncurses instead of termcap (bug #103105)
- epatch "${FILESDIR}/${P}-ncurses.patch"
+ eapply "${FILESDIR}/${P}-ncurses.patch"
# Fix Makefile.in to use our CFLAGS and LDFLAGS
sed -i -e "s/^CFLAGS=-O/CFLAGS=${CFLAGS}/" \
-e "s/^LDFLAGS=.*/LDFLAGS=${LDFLAGS}/" Makefile.in || die
# Rebuild the compilation framework
+ default
eautoreconf
}