summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-02 22:24:48 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-02 22:43:31 +0200
commita49b5e0e2025521d3653ea7458f74b98828a15a3 (patch)
tree1c0538c7beb7fca92512828f573fa14ccb99967c
parentdev-perl/Math-Int128: Also add -arm -ppc (diff)
downloadgentoo-a49b5e0e.tar.gz
gentoo-a49b5e0e.tar.bz2
gentoo-a49b5e0e.zip
dev-perl/Math-ModInt: Version bump 0.013
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--dev-perl/Math-ModInt/Manifest1
-rw-r--r--dev-perl/Math-ModInt/Math-ModInt-0.13.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-perl/Math-ModInt/Manifest b/dev-perl/Math-ModInt/Manifest
index 138c92309ed7..92e6052121f4 100644
--- a/dev-perl/Math-ModInt/Manifest
+++ b/dev-perl/Math-ModInt/Manifest
@@ -1 +1,2 @@
DIST Math-ModInt-0.011.tar.gz 40189 BLAKE2B 2b49dec27c7f67ab0c5005a850df9105d661aaa07fbb4041f9bb79bca621114edd6d541ef62d907e8fdc71d1879fb3eb522af232519cd0500b9d41fb2c1b6938 SHA512 c6a1b90e07dc6a4b620b0db63eaa205dad19ba3c96e8031f93d1c3fca137d5430e3c1e88d3bad9d3f6d64600bee4deb9c13e13fdad410c76f9c10732fd2495e0
+DIST Math-ModInt-0.013.tar.gz 53006 BLAKE2B 0889bfd9acd6e63b38ac20ef176580c0002db441e045f8298dd5c3b9d76471708f0b2955d137adfd93ba2315ee9d85040e0a1bac01d6a91a58b970842468b49b SHA512 ec69a8f0bcddae3175bf7b3f495697c0b33160db1bf8d71d7828d36065ade6bce2b1ddc135b3d09aaa590e550dc25ed2ae61731efb88a1a9b7582826dabca858
diff --git a/dev-perl/Math-ModInt/Math-ModInt-0.13.0.ebuild b/dev-perl/Math-ModInt/Math-ModInt-0.13.0.ebuild
new file mode 100644
index 000000000000..8eab610896dc
--- /dev/null
+++ b/dev-perl/Math-ModInt/Math-ModInt-0.13.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MHASCH
+DIST_VERSION=0.013
+
+inherit perl-module
+
+DESCRIPTION="modular integer arithmetic"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="minimal"
+LICENSE="Artistic-2"
+
+PERL_RM_FILES=(
+ "t/90_pod.t"
+ "t/91_pod_cover_cp.t"
+ "t/92_consistency.t"
+ "t/93_examples.t"
+ "t/95_versions.t"
+ "t/99_signature.t"
+)
+
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Math-BigInt-1.991.0
+ !minimal? (
+ dev-perl/Math-BigInt-GMP
+ virtual/perl-Math-BigRat
+ )
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ )
+"