summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-04 04:28:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-04 04:41:57 +0200
commita4a4493ab4a52aaf683c46b2a226166652ecbc6a (patch)
tree071f7f17729ca70da0589037cfa9b1cbc69b9e9b
parentdev-python/sqlglot: drop 17.8.6 (diff)
downloadgentoo-a4a4493a.tar.gz
gentoo-a4a4493a.tar.bz2
gentoo-a4a4493a.zip
dev-python/jupyterlab: Bump to 4.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyterlab/Manifest1
-rw-r--r--dev-python/jupyterlab/jupyterlab-4.0.4.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index c37142596b29..c1137c222c4c 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,2 +1,3 @@
DIST jupyterlab-3.6.3.tar.gz 16847186 BLAKE2B 6916722469ab100a1a240b8a565c9800f35535b2a9b2c39a6bfd275b078d88df9faa1f12d4ce3819155af7b0ed22282836f9b233534bd3e63d8a330d1cd7cd21 SHA512 3d6b4781f9fab02504b2c0223a4d060d80c3442fa6ac53ae326296d69942d68f8545450f671f6ba65c7c4e218aad62ef4f4ceb658899c21aaff3640c3055d364
DIST jupyterlab-4.0.3.tar.gz 18222352 BLAKE2B 7dee4109e94173d35794c2b3a05de5cbab145fc031b22628ca4b5c1d97497658807b0a9b713d58a7aae3a38a64a37e04e535988d727cab6ba3c3aebe2ff6c0a2 SHA512 cb7694c1398cbf1b061d385518d08d5ff4411bc7f53828d99edd3cf8420d39c09d99e1ee061d60a86d83e640c37777bfd4f98ce71276366f291f784f23740d4d
+DIST jupyterlab-4.0.4.tar.gz 18223782 BLAKE2B 8f2b157d27c68fba62fcfdeeb055b0c9b646987d2f31447b87720110ec2331ddad90c0288ad7554faa26674bf810d92d99f1924e2d34f81d2303a4ab6b213cd9 SHA512 23479cee2405ddc42a11c477cb93fad6cb5481a70766d48c1f7f1e498481c36a0dca47c5523ff3fc97aacfd86a37debd53cc3570e3e0916cc0a6cb526d99a574
diff --git a/dev-python/jupyterlab/jupyterlab-4.0.4.ebuild b/dev-python/jupyterlab/jupyterlab-4.0.4.ebuild
new file mode 100644
index 000000000000..01ca307b6a24
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-4.0.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi xdg
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/async-lru[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.19[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+ jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}