summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2022-04-16 10:23:37 -0700
committerSteve Arnold <nerdboy@gentoo.org>2022-04-16 10:24:38 -0700
commita4b33e6331916d82076c179692f1ec918a61b8ba (patch)
treeab6d9d95efd7e59e093eb65e6382287be941b5f7
parentsci-mathematics/coq-serapi: add ppx_sexp_conv version constraints (diff)
downloadgentoo-a4b33e63.tar.gz
gentoo-a4b33e63.tar.bz2
gentoo-a4b33e63.zip
dev-python/pystache: new/revived ebuild, dependency of gitchangelog
* revived, new upstream maintainer, new pypi package Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
-rw-r--r--dev-python/pystache/Manifest1
-rw-r--r--dev-python/pystache/metadata.xml14
-rw-r--r--dev-python/pystache/pystache-0.6.0.ebuild38
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pystache/Manifest b/dev-python/pystache/Manifest
new file mode 100644
index 000000000000..f75fabc9293b
--- /dev/null
+++ b/dev-python/pystache/Manifest
@@ -0,0 +1 @@
+DIST pystache-0.6.0.tar.gz 78240 BLAKE2B b3ba14090f7969b7d3bd77f6e23bda8007fbf6f750e008585676f48bb1a4bfc520484b2205225477f2d2d625b0d6c1500d875685fa50f87c11b19589b0d45622 SHA512 802e12795c3ae08fbde37c9e266a60478d46d55a42e2fc339389b664edf3c5ebb2e34069546b820789ad48ed9921f4a2b89f82bb37e72e94846eec0a9ba1568c
diff --git a/dev-python/pystache/metadata.xml b/dev-python/pystache/metadata.xml
new file mode 100644
index 000000000000..48edd0510f34
--- /dev/null
+++ b/dev-python/pystache/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+</maintainer>
+<longdescription lang="en">
+ Updated Python implementation of Mustache templating framework.
+</longdescription>
+<upstream>
+ <remote-id type="github">PennyDreadfulMTG/pystache</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/pystache/pystache-0.6.0.ebuild b/dev-python/pystache/pystache-0.6.0.ebuild
new file mode 100644
index 000000000000..bf1f4437fd2d
--- /dev/null
+++ b/dev-python/pystache/pystache-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS="pyproject.toml"
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of Mustache"
+HOMEPAGE="https://github.com/PennyDreadfulMTG/pystache"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/PennyDreadfulMTG/pystache.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="${PYTHON_DEPS}"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ distutils_install_for_testing
+ pystache-test . || die "Test failed with ${EPYTHON}"
+}