summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-21 15:24:38 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-21 15:26:37 +0200
commita4ea4c07e4c88848be304c81d0689ae5ffa82d1b (patch)
tree3574e125b49d17d0d06e67e10b55e3fda20ccf73
parentdev-perl/DateTime-Locale: Keyword 1.390.0 ppc, #908937 (diff)
downloadgentoo-a4ea4c07e4c88848be304c81d0689ae5ffa82d1b.tar.gz
gentoo-a4ea4c07e4c88848be304c81d0689ae5ffa82d1b.tar.bz2
gentoo-a4ea4c07e4c88848be304c81d0689ae5ffa82d1b.zip
app-containers/distrobox: bump to 1.5.0.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-containers/distrobox/Manifest1
-rw-r--r--app-containers/distrobox/distrobox-1.5.0.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-containers/distrobox/Manifest b/app-containers/distrobox/Manifest
index cee14d4848b6..c73a2ccf6260 100644
--- a/app-containers/distrobox/Manifest
+++ b/app-containers/distrobox/Manifest
@@ -1,2 +1,3 @@
DIST distrobox-1.4.2.1.tar.gz 235019 BLAKE2B dd512b183763a2e4c7e2b495bb50cc3fc3d764c48ce902b83e0b543587b60b458c6b9ae937057bfc91860dc415f9ad68fb648cf06faeeb56d0a4c27180e4c2e0 SHA512 d3bc1de91bf33b7ac500c0ae471feb28c9b1efdef6878bf1aed50ef394f69d2d36f99296f0a8182b139d9339558720b891f7dc1249a7f91c883c00bac5597283
+DIST distrobox-1.5.0.1.tar.gz 5899694 BLAKE2B d47457908da7193bdc40608c51de2151dc5c5b8b8302fbe960dbcee646db51d0e9d581bf90be094264042e170267b6c9fc2a0a7d9808f84517f7adac3499ca4f SHA512 3f65662e5d1236d8ee5d51a3c65bfaf1e0047ba348f75e451f5f5f723a4b9c2029d9d90395af49d94daa908844282481ca98906e2456468ea1941ce3b21c30a2
DIST distrobox-1.5.0.tar.gz 5906290 BLAKE2B a1a3279e0644e140d38518e4f038bdd4fdb9170675443b3c8cb0c1b4144938a03449eab8b6259b20417069d58ba6e9e1bbb7124d50dd91e706e6f5397287d7c1 SHA512 3bd48b2715a6b9c2bd7457e84fca45e8893f90e6ea6d18d33c9581625e37f2169c03bc1029c339dd41cec6de8037063c040d3e2c22afb4995863171c8ff452c4
diff --git a/app-containers/distrobox/distrobox-1.5.0.1.ebuild b/app-containers/distrobox/distrobox-1.5.0.1.ebuild
new file mode 100644
index 000000000000..b9fc4f8ee11b
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.5.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.privatedns.org/
+ https://github.com/89luca89/distrobox/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}"/usr || die "${PN} install script failed"
+ dodoc *.md
+}