summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-04-09 18:21:57 -0400
committerSam James <sam@gentoo.org>2023-04-10 06:21:34 +0100
commita5064961fea762cf204de7bed03e018dbaf5acee (patch)
treef990ac43c096c22e0875bc5a1208d89581bc2348
parentdev-python/importlib_metadata: Stabilize 6.0.1 ALLARCHES, #904088 (diff)
downloadgentoo-a5064961.tar.gz
gentoo-a5064961.tar.bz2
gentoo-a5064961.zip
gui-apps/waybar: add several USE flags
evdev, jack, libinput, logind, mpris, pipewire, systemd, test, upower drop net-wireless/rfkill DEPEND Closes: https://bugs.gentoo.org/894068 Signed-off-by: Julien Roy <julien@jroy.ca> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--gui-apps/waybar/files/systemd-0.9.17.patch35
-rw-r--r--gui-apps/waybar/metadata.xml7
-rw-r--r--gui-apps/waybar/waybar-0.9.17-r1.ebuild102
-rw-r--r--gui-apps/waybar/waybar-9999.ebuild46
4 files changed, 181 insertions, 9 deletions
diff --git a/gui-apps/waybar/files/systemd-0.9.17.patch b/gui-apps/waybar/files/systemd-0.9.17.patch
new file mode 100644
index 000000000000..7d6c8dd10b38
--- /dev/null
+++ b/gui-apps/waybar/files/systemd-0.9.17.patch
@@ -0,0 +1,35 @@
+diff --git a/meson.build b/meson.build
+index ebf68d4..3c2a7fd 100644
+--- a/meson.build
++++ b/meson.build
+@@ -122,7 +122,6 @@ endif
+ gtk_layer_shell = dependency('gtk-layer-shell-0',
+ required: get_option('gtk-layer-shell'),
+ fallback : ['gtk-layer-shell', 'gtk_layer_shell_dep'])
+-systemd = dependency('systemd', required: get_option('systemd'))
+ tz_dep = dependency('date',
+ required: false,
+ default_options : [ 'use_system_tzdb=true' ],
+@@ -136,16 +135,12 @@ conf_data.set('prefix', prefix)
+
+ add_project_arguments('-DSYSCONFDIR="/@0@"'.format(join_paths(prefix, sysconfdir)), language : 'cpp')
+
+-if systemd.found()
+- user_units_dir = systemd.get_pkgconfig_variable('systemduserunitdir')
+-
+- configure_file(
+- configuration: conf_data,
+- input: './resources/waybar.service.in',
+- output: '@BASENAME@',
+- install_dir: user_units_dir
+- )
+-endif
++configure_file(
++ configuration: conf_data,
++ input: './resources/waybar.service.in',
++ output: '@BASENAME@',
++ install_dir: '/usr/lib/systemd/user'
++)
+
+ src_files = files(
+ 'src/factory.cpp',
diff --git a/gui-apps/waybar/metadata.xml b/gui-apps/waybar/metadata.xml
index b481b93d48a5..78b89e6579cc 100644
--- a/gui-apps/waybar/metadata.xml
+++ b/gui-apps/waybar/metadata.xml
@@ -14,11 +14,16 @@
<name>Proxy Maintainers</name>
</maintainer>
<use>
- <flag name="experimental">Enable experimental features</flag>
+ <flag name="experimental">Enable experimental features, such as Bluetooth battery reporting</flag>
+ <flag name="evdev">Enable libevdev support for evdev related features</flag>
+ <flag name="libinput">Enable libinput support for libinput related features</flag>
+ <flag name="logind">Enable support for logind</flag>
<flag name="mpd">Enable support for the Music Player Daemon</flag>
+ <flag name="mpris">Enable support for mpris</flag>
<flag name="network">Enable libnl support for network related features</flag>
<flag name="popups">Enable popup support with gtk-layer-shell</flag>
<flag name="sndio">Enable support for volume control via sndio</flag>
+ <flag name="pipewire">Enable support for pipewire</flag>
<flag name="pulseaudio">Enable support for volume control via PulseAudio</flag>
<flag name="tray">Enable support for tray</flag>
<flag name="wifi">Enable support for wifi/rfkill</flag>
diff --git a/gui-apps/waybar/waybar-0.9.17-r1.ebuild b/gui-apps/waybar/waybar-0.9.17-r1.ebuild
new file mode 100644
index 000000000000..9ee87022a46b
--- /dev/null
+++ b/gui-apps/waybar/waybar-0.9.17-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors"
+HOMEPAGE="https://github.com/Alexays/Waybar"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
+else
+ SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN^}-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="evdev experimental jack libinput logind mpd mpris network +popups pipewire pulseaudio sndio test tray +udev upower wifi"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=app-text/scdoc-1.9.2
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-cpp/cairomm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-libs/glib:2
+ dev-libs/jsoncpp:=
+ dev-libs/libinput:=
+ dev-libs/libsigc++:2
+ >=dev-libs/libfmt-7.0.0:=
+ >=dev-libs/spdlog-1.8.5:=
+ dev-libs/date:=
+ dev-libs/wayland
+ gui-libs/wlroots:=
+ x11-libs/gtk+:3[wayland]
+ x11-libs/libxkbcommon
+ evdev? ( dev-libs/libevdev:= )
+ jack? ( virtual/jack )
+ libinput? ( dev-libs/libinput:= )
+ logind? (
+ || ( sys-apps/systemd
+ sys-auth/elogind )
+ )
+ mpd? ( media-libs/libmpdclient )
+ mpris? ( >=media-sound/playerctl-2 )
+ network? ( dev-libs/libnl:3 )
+ popups? ( gui-libs/gtk-layer-shell )
+ pipewire? ( media-video/wireplumber:0/0.4 )
+ pulseaudio? ( media-sound/pulseaudio[daemon] )
+ sndio? ( media-sound/sndio:= )
+ tray? (
+ dev-libs/libdbusmenu[gtk3]
+ dev-libs/libappindicator
+ )
+ udev? ( virtual/libudev:= )
+ upower? ( sys-power/upower )
+ wifi? ( sys-apps/util-linux )
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+ test? ( dev-cpp/catch:0 )
+"
+
+PATCHES=(
+ "${FILESDIR}/waybar-0.9.17-wireplumber.patch"
+ "${FILESDIR}/waybar-0.9.17-gcc13.patch"
+ "${FILESDIR}/systemd-0.9.17.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ -Dsystemd=enabled
+ $(meson_feature evdev libevdev)
+ $(meson_feature jack)
+ $(meson_feature libinput)
+ $(meson_feature logind)
+ $(meson_feature mpd)
+ $(meson_feature mpris)
+ $(meson_feature network libnl)
+ $(meson_feature popups gtk-layer-shell)
+ $(meson_feature pulseaudio)
+ $(meson_feature pipewire wireplumber)
+ $(meson_feature sndio)
+ $(meson_feature test tests)
+ $(meson_feature tray dbusmenu-gtk)
+ $(meson_feature udev libudev)
+ $(meson_feature upower upower_glib)
+ $(meson_feature wifi rfkill)
+ $(meson_use experimental)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/waybar/waybar-9999.ebuild b/gui-apps/waybar/waybar-9999.ebuild
index d3aca7df27b2..b08f76f5d66f 100644
--- a/gui-apps/waybar/waybar-9999.ebuild
+++ b/gui-apps/waybar/waybar-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,18 +14,21 @@ if [[ ${PV} == 9999 ]]; then
else
SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN^}-${PV}"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="mpd network +popups pulseaudio sndio tray +udev wifi"
+IUSE="evdev experimental jack libinput logind mpd mpris network +popups pipewire pulseaudio sndio test tray +udev upower wifi"
+
+RESTRICT="!test? ( test )"
BDEPEND="
>=app-text/scdoc-1.9.2
dev-util/gdbus-codegen
virtual/pkgconfig
"
-DEPEND="
+RDEPEND="
dev-cpp/cairomm:0
dev-cpp/glibmm:2
dev-cpp/gtkmm:3.0
@@ -33,38 +36,65 @@ DEPEND="
dev-libs/jsoncpp:=
dev-libs/libinput:=
dev-libs/libsigc++:2
- >=dev-libs/libfmt-5.3.0:=
+ >=dev-libs/libfmt-7.0.0:=
>=dev-libs/spdlog-1.8.5:=
dev-libs/date:=
dev-libs/wayland
- dev-libs/wayland-protocols
gui-libs/wlroots:=
x11-libs/gtk+:3[wayland]
x11-libs/libxkbcommon
+ evdev? ( dev-libs/libevdev:= )
+ jack? ( virtual/jack )
+ libinput? ( dev-libs/libinput:= )
+ logind? (
+ || ( sys-apps/systemd
+ sys-auth/elogind )
+ )
mpd? ( media-libs/libmpdclient )
+ mpris? ( >=media-sound/playerctl-2 )
network? ( dev-libs/libnl:3 )
popups? ( gui-libs/gtk-layer-shell )
- pulseaudio? ( media-sound/pulseaudio )
+ pipewire? ( media-video/wireplumber:0/0.4 )
+ pulseaudio? ( media-sound/pulseaudio[daemon] )
sndio? ( media-sound/sndio:= )
tray? (
dev-libs/libdbusmenu[gtk3]
dev-libs/libappindicator
)
udev? ( virtual/libudev:= )
- wifi? ( || ( sys-apps/util-linux net-wireless/rfkill ) )
+ upower? ( sys-power/upower )
+ wifi? ( sys-apps/util-linux )
"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+ test? ( dev-cpp/catch:0 )
+"
+
+PATCHES=(
+ "${FILESDIR}/systemd-0.9.17.patch"
+)
src_configure() {
local emesonargs=(
+ -Dman-pages=enabled
+ -Dsystemd=enabled
+ $(meson_feature evdev libevdev)
+ $(meson_feature jack)
+ $(meson_feature libinput)
+ $(meson_feature logind)
$(meson_feature mpd)
+ $(meson_feature mpris)
$(meson_feature network libnl)
$(meson_feature popups gtk-layer-shell)
$(meson_feature pulseaudio)
+ $(meson_feature pipewire wireplumber)
$(meson_feature sndio)
+ $(meson_feature test tests)
$(meson_feature tray dbusmenu-gtk)
$(meson_feature udev libudev)
+ $(meson_feature upower upower_glib)
$(meson_feature wifi rfkill)
+ $(meson_use experimental)
)
meson_src_configure
}