summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-08-25 18:03:54 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-08-27 05:22:12 -0400
commita52f8d961e5359a29ce7e855da4e88f098ce533e (patch)
tree95f5686cb38f41eb8f2984d8516a4ebbbce50e01
parentapp-portage/iwdevtools: drop 0.3.2 (diff)
downloadgentoo-a52f8d961e5359a29ce7e855da4e88f098ce533e.tar.gz
gentoo-a52f8d961e5359a29ce7e855da4e88f098ce533e.tar.bz2
gentoo-a52f8d961e5359a29ce7e855da4e88f098ce533e.zip
games-action/xpilot: EAPI8, minor improvements
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/22101 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-action/xpilot/Manifest1
-rw-r--r--games-action/xpilot/xpilot-4.5.5-r1.ebuild43
2 files changed, 27 insertions, 17 deletions
diff --git a/games-action/xpilot/Manifest b/games-action/xpilot/Manifest
index dc9475dc910d..ac0b093502d3 100644
--- a/games-action/xpilot/Manifest
+++ b/games-action/xpilot/Manifest
@@ -1 +1,2 @@
DIST xpilot-4.5.5.tar.bz2 1115502 BLAKE2B 9f7758dabc834f9ffad602e2ba215e1e08ff3f33b21480eae0176775d6c55df3e3238652e0cbbbc688acbab9e23395f46d853ee52fd55d177fdace5138621335 SHA512 002fbdbee3035e21f441d749d68ac41da2816a691e1c0d1cf9de9cddaa479c92da57eb36081884b9908a6ae83454f6f532c24c89280d27e2cbf9570442ef301c
+DIST xpilot.png 9682 BLAKE2B 689ac9d6efe54ee1d8c166543cd7c720ebd71c05818b074dffdcb1499d645c3cb9f9db00ce8c6f29d433255d0f58e2d30897f1438c0b41e13f5fd2043e5bac46 SHA512 5a59f01399b03852a795f5c475ce64cf2890e102b806c5e3540c635ad32d1a16f6a0e2c4dd8d0de0a33a9fbc907b68640f151905b71a54556b59a83602036f95
diff --git a/games-action/xpilot/xpilot-4.5.5-r1.ebuild b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
index c90d59c476c1..28e96af330c1 100644
--- a/games-action/xpilot/xpilot-4.5.5-r1.ebuild
+++ b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
@@ -1,35 +1,44 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit desktop toolchain-funcs
-DESCRIPTION="A multi-player 2D client/server space game"
+DESCRIPTION="Multi-player 2D client/server space game"
HOMEPAGE="http://www.xpilot.org/"
-SRC_URI="mirror://sourceforge/xpilotgame/${P}.tar.bz2"
+SRC_URI="
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png
+ mirror://sourceforge/xpilotgame/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
app-text/rman
- x11-base/xorg-proto
x11-misc/gccmakedep
>=x11-misc/imake-1.0.8-r1"
+DOCS=(
+ README.txt
+ doc/{ChangeLog,CREDITS,FAQ,TODO}
+ doc/README.{MAPS,MAPS2,SHIPS,sounds,talkmacros}
+)
+
src_prepare() {
- #default
- eapply_user
+ default
sed -i \
- -e '/^INSTMAN/s:=.*:=/usr/share/man/man6:' \
- -e "/^INSTLIB/s:=.*:=/usr/share/${PN}:" \
- -e "/^INSTBIN/s:=.*:=/usr/bin:" \
+ -e "/^INSTMAN/s|=.*|=${EPREFIX}/usr/share/man/man6|" \
+ -e "/^INSTLIB/s|=.*|=${EPREFIX}/usr/share/${PN}|" \
+ -e "/^INSTBIN/s|=.*|=${EPREFIX}/usr/bin|" \
Local.config || die
# work with glibc-2.20
@@ -53,9 +62,9 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
emake DESTDIR="${D}" install.man
- newicon lib/textures/logo.ppm ${PN}.ppm
- make_desktop_entry ${PN} XPilot /usr/share/pixmaps/${PN}.ppm
- dodoc README.txt doc/{ChangeLog,CREDITS,FAQ,README*,TODO}
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} XPilot
}