summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <rahil3108@gmail.com>2023-09-21 16:22:59 +0530
committerSam James <sam@gentoo.org>2023-09-21 23:16:18 +0100
commita54135c5dbd51b436434970721c07a566c784436 (patch)
tree7e5598da99a2eafe4606415bb3eaa29f873c5d37
parentapp-containers/containers-shortnames: add 2023.02.20 and live (diff)
downloadgentoo-a54135c5dbd51b436434970721c07a566c784436.tar.gz
gentoo-a54135c5dbd51b436434970721c07a566c784436.tar.bz2
gentoo-a54135c5dbd51b436434970721c07a566c784436.zip
app-containers/containers-image: add 5.28.0 and live
app-containers/containers-common depends on this Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-containers/containers-image/Manifest1
-rw-r--r--app-containers/containers-image/containers-image-5.28.0.ebuild45
-rw-r--r--app-containers/containers-image/containers-image-9999.ebuild45
-rw-r--r--app-containers/containers-image/files/fix-warnings.patch14
-rw-r--r--app-containers/containers-image/metadata.xml17
5 files changed, 122 insertions, 0 deletions
diff --git a/app-containers/containers-image/Manifest b/app-containers/containers-image/Manifest
new file mode 100644
index 000000000000..386995e8ccba
--- /dev/null
+++ b/app-containers/containers-image/Manifest
@@ -0,0 +1 @@
+DIST containers-image-5.28.0.tar.gz 688100 BLAKE2B 0cee8be579bd11eb0524590d8afe16b6ef863d7adfd74db51b68385142804c8096fec3f2a492e0d5a5021eba9edc91219b327138635aaa329c6ef7d0c01129c8 SHA512 0b76539e04016f5f1067c576a877ace475f25d0f0840fc969606601105a8a7f0e242cc054b0a2cfb6f1b751d850734360a524c78563fdf2330c8ae8c11bba1cf
diff --git a/app-containers/containers-image/containers-image-5.28.0.ebuild b/app-containers/containers-image/containers-image-5.28.0.ebuild
new file mode 100644
index 000000000000..a29e5e602b78
--- /dev/null
+++ b/app-containers/containers-image/containers-image-5.28.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Default config and docs related to Containers' images"
+HOMEPAGE="https://github.com/containers/image"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/image.git"
+else
+ SRC_URI="https://github.com/containers/image/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND=">=dev-go/go-md2man-2.0.2"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/fix-warnings.patch"
+}
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ emake docs
+}
+
+src_test() {
+ return
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/containers
+ doins registries.conf
+}
diff --git a/app-containers/containers-image/containers-image-9999.ebuild b/app-containers/containers-image/containers-image-9999.ebuild
new file mode 100644
index 000000000000..a29e5e602b78
--- /dev/null
+++ b/app-containers/containers-image/containers-image-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Default config and docs related to Containers' images"
+HOMEPAGE="https://github.com/containers/image"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/image.git"
+else
+ SRC_URI="https://github.com/containers/image/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND=">=dev-go/go-md2man-2.0.2"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/fix-warnings.patch"
+}
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ emake docs
+}
+
+src_test() {
+ return
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/containers
+ doins registries.conf
+}
diff --git a/app-containers/containers-image/files/fix-warnings.patch b/app-containers/containers-image/files/fix-warnings.patch
new file mode 100644
index 000000000000..c68cffa8584b
--- /dev/null
+++ b/app-containers/containers-image/files/fix-warnings.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -5,7 +5,2 @@
+
+-GOBIN := $(shell go env GOBIN)
+-ifeq ($(GOBIN),)
+-GOBIN := $(shell go env GOPATH)/bin
+-endif
+-
+ # when cross compiling _for_ a Darwin or windows host, then we must use openpgp
+@@ -17,3 +12,2 @@
+
+-PACKAGES := $(shell GO111MODULE=on go list $(BUILDFLAGS) ./...)
+ SOURCE_DIRS = $(shell echo $(PACKAGES) | awk 'BEGIN{FS="/"; RS=" "}{print $$4}' | uniq)
diff --git a/app-containers/containers-image/metadata.xml b/app-containers/containers-image/metadata.xml
new file mode 100644
index 000000000000..4296f17b57ba
--- /dev/null
+++ b/app-containers/containers-image/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>rahil3108@gmail.com</email>
+ <name>Rahil Bhimjiani</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">containers/image</remote-id>
+ <bugs-to>https://github.com/containers/image/issues</bugs-to>
+ <doc>https://github.com/containers/image/blob/main/README.md</doc>
+ </upstream>
+</pkgmetadata>