summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-05 21:48:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-05 21:49:50 +0200
commita569309d64cac57c8e09a8a923428e074c99c381 (patch)
tree38f1ae9c22aaad848976e228a5c0ade65a29f57d
parentsys-devel/llvm: Add 16.* live ebuilds (diff)
downloadgentoo-a569309d64cac57c8e09a8a923428e074c99c381.tar.gz
gentoo-a569309d64cac57c8e09a8a923428e074c99c381.tar.bz2
gentoo-a569309d64cac57c8e09a8a923428e074c99c381.zip
sys-devel/llvmgold: Add 16.* live ebuilds
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/llvmgold/llvmgold-16.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/llvmgold/llvmgold-16.ebuild b/sys-devel/llvmgold/llvmgold-16.ebuild
new file mode 100644
index 000000000000..5dcc3164a55c
--- /dev/null
+++ b/sys-devel/llvmgold/llvmgold-16.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="LLVMgold plugin symlink for autoloading"
+HOMEPAGE="https://llvm.org/"
+S=${WORKDIR}
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS=""
+PROPERTIES="live"
+
+RDEPEND="
+ sys-devel/llvm:${PV}[binutils-plugin]
+ !sys-devel/llvm:0
+"
+
+src_install() {
+ dodir "/usr/${CHOST}/binutils-bin/lib/bfd-plugins"
+ dosym "../../../../lib/llvm/${PV}/$(get_libdir)/LLVMgold.so" \
+ "/usr/${CHOST}/binutils-bin/lib/bfd-plugins/LLVMgold.so"
+}