summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-12 17:05:46 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-12 18:51:36 +0100
commita5759bd5d358886b5e28655367004bd354cfa63d (patch)
tree87349563862cd9131a410fd620f1bc291027269a
parentdev-python/terminado: Bump to 0.18.1 (diff)
downloadgentoo-a5759bd5d358886b5e28655367004bd354cfa63d.tar.gz
gentoo-a5759bd5d358886b5e28655367004bd354cfa63d.tar.bz2
gentoo-a5759bd5d358886b5e28655367004bd354cfa63d.zip
dev-python/nbformat: Bump to 5.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/nbformat-5.10.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index 2854d2600c5d..1547499d24aa 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1 +1,2 @@
+DIST nbformat-5.10.2.tar.gz 142443 BLAKE2B 7089b27f2ed05e2240e12f583ed6d73aeace54939f235cdd41dede0f410a15927dd4223af0f9a8072bdaef15c3c737941c69313ee27abf69784df302677624b1 SHA512 a68e3261bd5a3126bb31a99fce3e85daad3651a39844f1fadf499c25af76b3b544188a7ece4d248534c4b3f3d3eca7a1caff17f0beaec9b866e989e76c666316
DIST nbformat-5.9.2.tar.gz 141264 BLAKE2B 71f5bb447d675b10276565cb53ac193963e5161fd27e925d639e7aa63f1e69db8903974d2f924ad5456940c4b904aba33d8ab10772fdb70e7e67974a90d1f3d6 SHA512 886a03cf95b39cdca48ae46d4946cee0f3dc1f5fa0e9dac7c6184b4c3e326adb739bd9da28032868a973577aa949feb5ae95a84017755948610ef7f208ebc5db
diff --git a/dev-python/nbformat/nbformat-5.10.2.ebuild b/dev-python/nbformat/nbformat-5.10.2.ebuild
new file mode 100644
index 000000000000..0bf953fb87b2
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.10.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbformat/
+ https://pypi.org/project/nbformat/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/nbformat-5.7.1-no-node.patch"
+)
+
+EPYTEST_IGNORE=(
+ # requires pep440 package, which is not really relevant for us
+ tests/test_api.py
+)