summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-04-25 22:34:53 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-04-25 22:36:23 +0100
commita5aeba894b4358fc24b6c0d76d17b79e5cb47048 (patch)
treeb8e060b7ac7887930d6cd76e1a29cbd24b6bc1b2
parentdev-libs/weston: Update mesa[gles2] dependency now that flag has gone (diff)
downloadgentoo-a5aeba894b4358fc24b6c0d76d17b79e5cb47048.tar.gz
gentoo-a5aeba894b4358fc24b6c0d76d17b79e5cb47048.tar.bz2
gentoo-a5aeba894b4358fc24b6c0d76d17b79e5cb47048.zip
net-misc/netevent: Bump to 2.2.2, fix building with newer docutils
Closes: https://bugs.gentoo.org/930666 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--net-misc/netevent/Manifest1
-rw-r--r--net-misc/netevent/netevent-2.2.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/netevent/Manifest b/net-misc/netevent/Manifest
index de7b2ab75191..078422d988c5 100644
--- a/net-misc/netevent/Manifest
+++ b/net-misc/netevent/Manifest
@@ -1,2 +1,3 @@
DIST netevent-2.0_p20200217.tar.gz 39237 BLAKE2B 543456de89c6c57c7fe086d6697ca687ce0a04fce67efda7162e516eb1dca3f31b6ce31e1f5d7481fe538364f9f597103e3b77f3864c41456c6fe9080bfb424a SHA512 921982c8d9153e627c7931059e6163213ba2ac907f4ae98bcde62645e774cc41077ee728b698f3fad6a639fda19f99f9e43103006abe645f1a4ac4d68cf393c7
DIST netevent-2.2.1.tar.gz 40826 BLAKE2B 7620ecaead747f0684bd9f9ce0c8c3126cc67b9eafa747f43986f9e0f162f771604b4ec0e9aa070f773d4bd535a98d3164dbc9a868e1dc72ddd8063f0cd45559 SHA512 f597b82f7343b9f22c9c8533d9821763e82aeb0afddcfa109499555a6ed1e32f00f3cc9f36fe3eb5d524ad594e861382e33168ea4033a68abd15385b8edaeab9
+DIST netevent-2.2.2.tar.gz 40889 BLAKE2B a52a6b352d8f842aeb85f7c4d82ed1c5008966893ec7bc3236d212b988470a051d0c5d6dca1f36029b3a83c4c908cd7d64e5cd0203b0677857dd66613a0f2c5a SHA512 bd993529d69b18a1774042f61fe891fedba96d2d630dbe066c9d9b88d18268eaad49062c76f688712a927e495f29e7b176da64676c6ef6109b2e92117ef00e1b
diff --git a/net-misc/netevent/netevent-2.2.2.ebuild b/net-misc/netevent/netevent-2.2.2.ebuild
new file mode 100644
index 000000000000..c882e035e5cd
--- /dev/null
+++ b/net-misc/netevent/netevent-2.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to share Linux event devices with other machines"
+HOMEPAGE="https://github.com/Blub/netevent"
+SRC_URI="https://github.com/Blub/netevent/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="doc"
+
+BDEPEND="
+ doc? ( dev-python/docutils )
+"
+
+src_configure() {
+ tc-export CXX
+
+ # Not Autoconf.
+ RST2MAN=$(type -P rst2man rst2man.py) \
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ $(use_enable doc) \
+ || die
+}
+
+src_compile() {
+ emake CPPFLAGS="-Wall -Wno-unknown-pragmas"
+}