summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-08-09 18:04:53 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2016-08-09 18:05:34 +0300
commita5bca1e5bc0a70d6acb0a0887bf914bda80cd743 (patch)
tree45be746c8c3d57ea5c569c626cb1842ae30d974c
parentdev-php/pecl-geoip: Revbump with unreleased upstream patches wrt bug 590850 (diff)
downloadgentoo-a5bca1e5bc0a70d6acb0a0887bf914bda80cd743.tar.gz
gentoo-a5bca1e5bc0a70d6acb0a0887bf914bda80cd743.tar.bz2
gentoo-a5bca1e5bc0a70d6acb0a0887bf914bda80cd743.zip
net-libs/gnutls: add tls-heartbeat, sslv2, sslv3 USE flags
Bug: 590856 Package-Manager: portage-2.2.28
-rw-r--r--net-libs/gnutls/gnutls-3.4.14.ebuild9
-rw-r--r--net-libs/gnutls/gnutls-3.5.3.ebuild11
-rw-r--r--net-libs/gnutls/metadata.xml9
3 files changed, 17 insertions, 12 deletions
diff --git a/net-libs/gnutls/gnutls-3.4.14.ebuild b/net-libs/gnutls/gnutls-3.4.14.ebuild
index ed0dc898806e..d6af3157d937 100644
--- a/net-libs/gnutls/gnutls-3.4.14.ebuild
+++ b/net-libs/gnutls/gnutls-3.4.14.ebuild
@@ -10,14 +10,11 @@ DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
HOMEPAGE="http://www.gnutls.org/"
SRC_URI="mirror://gnupg/gnutls/v$(get_version_component_range 1-2)/${P}.tar.xz"
-# LGPL-3 for libgnutls library and GPL-3 for libgnutls-extra library.
-# soon to be relicensed as LGPL-2.1 unless heartbeat extension enabled.
-LICENSE="GPL-3 LGPL-3"
+LICENSE="GPL-3 LGPL-2.1"
SLOT="0/30" # libgnutls.so number
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE_LINGUAS=" en cs de fi fr it ms nl pl sv uk vi zh_CN"
-IUSE="+cxx +crywrap dane doc examples guile nls +openssl pkcs11 static-libs test +tools zlib ${IUSE_LINGUAS// / linguas_}"
-# heartbeat support is not disabled until re-licensing happens fullyf
+IUSE="+cxx +crywrap dane doc examples guile nls +openssl pkcs11 static-libs test +tls-heartbeat +tools zlib ${IUSE_LINGUAS// / linguas_}"
# NOTICE: sys-devel/autogen is required at runtime as we
# use system libopts
@@ -96,7 +93,6 @@ multilib_src_configure() {
econf \
--disable-valgrind-tests \
--without-included-libtasn1 \
- --enable-heartbeat-support \
$(use_enable cxx) \
$(use_enable dane libdane) \
$(multilib_native_enable manpages) \
@@ -108,6 +104,7 @@ multilib_src_configure() {
$(multilib_native_use_enable test tests) \
$(use_enable nls) \
$(use_enable openssl openssl-compatibility) \
+ $(use_enable tls-heartbeat heartbeat-support) \
$(use_enable static-libs static) \
$(use_with pkcs11 p11-kit) \
$(use_with zlib) \
diff --git a/net-libs/gnutls/gnutls-3.5.3.ebuild b/net-libs/gnutls/gnutls-3.5.3.ebuild
index efe688485ad4..117fc944cc5a 100644
--- a/net-libs/gnutls/gnutls-3.5.3.ebuild
+++ b/net-libs/gnutls/gnutls-3.5.3.ebuild
@@ -10,14 +10,11 @@ DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
HOMEPAGE="http://www.gnutls.org/"
SRC_URI="mirror://gnupg/gnutls/v$(get_version_component_range 1-2)/${P}.tar.xz"
-# LGPL-3 for libgnutls library and GPL-3 for libgnutls-extra library.
-# soon to be relicensed as LGPL-2.1 unless heartbeat extension enabled.
-LICENSE="GPL-3 LGPL-3"
+LICENSE="GPL-3 LGPL-2.1"
SLOT="0/30" # libgnutls.so number
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE_LINGUAS=" en cs de fi fr it ms nl pl sv uk vi zh_CN"
-IUSE="+cxx dane doc examples guile nls +openssl pkcs11 static-libs test +tools zlib ${IUSE_LINGUAS// / linguas_}"
-# heartbeat support is not disabled until re-licensing happens fullyf
+IUSE="+cxx dane doc examples guile nls +openssl pkcs11 sslv2 +sslv3 static-libs test +tls-heartbeat +tools zlib ${IUSE_LINGUAS// / linguas_}"
# NOTICE: sys-devel/autogen is required at runtime as we
# use system libopts
@@ -89,7 +86,6 @@ multilib_src_configure() {
econf \
--disable-valgrind-tests \
--without-included-libtasn1 \
- --enable-heartbeat-support \
$(use_enable cxx) \
$(use_enable dane libdane) \
$(multilib_native_enable manpages) \
@@ -100,6 +96,9 @@ multilib_src_configure() {
$(multilib_native_use_enable test tests) \
$(use_enable nls) \
$(use_enable openssl openssl-compatibility) \
+ $(use_enable tls-heartbeat heartbeat-support) \
+ $(use_enable sslv2 ssl2-support) \
+ $(use_enable sslv3 ssl3-support) \
$(use_enable static-libs static) \
$(use_with pkcs11 p11-kit) \
$(use_with zlib) \
diff --git a/net-libs/gnutls/metadata.xml b/net-libs/gnutls/metadata.xml
index 615fc411a920..7abdcd062226 100644
--- a/net-libs/gnutls/metadata.xml
+++ b/net-libs/gnutls/metadata.xml
@@ -22,6 +22,15 @@
<flag name="tools">
Build extra tools
</flag>
+ <flag name="tls-heartbeat">
+ Enable the Heartbeat Extension in TLS and DTLS
+ </flag>
+ <flag name="sslv2">
+ Support for the old/insecure SSLv2 protocol
+ </flag>
+ <flag name="sslv3">
+ Support for the old/insecure SSLv3 protocol
+ </flag>
</use>
<slots>
<subslots>Reflect ABI compatibility of libgnutls.so</subslots>