summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-03-01 09:04:44 -0500
committerCraig Andrews <candrews@gentoo.org>2021-03-01 09:07:28 -0500
commita5dbc08692ca0c8dc01ab8b1172689636956ba70 (patch)
tree38f1cdcdc9f7efd10ff158aec80bcc507d5979ce
parentdev-ml/ppxlib: move some dep under test ? (diff)
downloadgentoo-a5dbc086.tar.gz
gentoo-a5dbc086.tar.bz2
gentoo-a5dbc086.zip
media-plugins/kodi-pvr-vuplus: 7.4.0 version bump
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--media-plugins/kodi-pvr-vuplus/Manifest1
-rw-r--r--media-plugins/kodi-pvr-vuplus/kodi-pvr-vuplus-7.4.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-vuplus/Manifest b/media-plugins/kodi-pvr-vuplus/Manifest
index eafe12f7768a..7a7d8ed8e423 100644
--- a/media-plugins/kodi-pvr-vuplus/Manifest
+++ b/media-plugins/kodi-pvr-vuplus/Manifest
@@ -1 +1,2 @@
DIST kodi-pvr-vuplus-7.3.3.tar.gz 273471 BLAKE2B 1b16cce69c15fc5bf1cf188db2fe5f3178025692d37125b8e5ed43a4c92539f0b5fb616f651223a184483cf8883dfc917fd2e18fdb1f16ef2402e2c10ecc9415 SHA512 5b4cb03eca2d904b091d271576b943ce69b79f3f7468e0d415abe90717903623204831fcbe1118e2d105fc3570a32bd972f8c4ec0dccdf9f427069d8081ec501
+DIST kodi-pvr-vuplus-7.4.0.tar.gz 274465 BLAKE2B 8186329d833e1d06d11f9d22367b5cb8b09f30696550d498384b80032799eaa3ec29cb650529c5fe220e67e80e5ed511e7900851eb73569018445b87a4f51f47 SHA512 01a81d004959193a0428e56eecbd0b41912304882e986736f9f11a4a06e85cea5d615c0efeea9236f1d4acb8a3faf588d5b9d7ebb4b15f76cf02d1d86de326ce
diff --git a/media-plugins/kodi-pvr-vuplus/kodi-pvr-vuplus-7.4.0.ebuild b/media-plugins/kodi-pvr-vuplus/kodi-pvr-vuplus-7.4.0.ebuild
new file mode 100644
index 000000000000..20323489f843
--- /dev/null
+++ b/media-plugins/kodi-pvr-vuplus/kodi-pvr-vuplus-7.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Kodi's VuPlus client addon"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.vuplus"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.vuplus.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.vuplus/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.vuplus-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ dev-libs/tinyxml
+ dev-cpp/nlohmann_json
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "
+
+src_prepare() {
+ [ -d depends ] && rm -rf depends || die
+ cmake_src_prepare
+}