summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-01 15:48:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-01 15:48:05 +0200
commita5e476b9a0f486738ae0707a24c2624236ee2a83 (patch)
treeb103eac85c41bf12764b3bb78bd25774573643ae
parentdev-python/cheetah3: Bump to 3.2.6_p2 (diff)
downloadgentoo-a5e476b9a0f486738ae0707a24c2624236ee2a83.tar.gz
gentoo-a5e476b9a0f486738ae0707a24c2624236ee2a83.tar.bz2
gentoo-a5e476b9a0f486738ae0707a24c2624236ee2a83.zip
dev-python/odfpy: Bump to 1.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/odfpy/Manifest1
-rw-r--r--dev-python/odfpy/odfpy-1.4.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/odfpy/Manifest b/dev-python/odfpy/Manifest
index b05bb2bee801..9fa4b87c292d 100644
--- a/dev-python/odfpy/Manifest
+++ b/dev-python/odfpy/Manifest
@@ -1 +1,2 @@
DIST odfpy-1.3.6.tar.gz 691122 BLAKE2B aaaf2c1613beb6775d22e4d1739b7c144d8046e687f0dc8f7b7b1ea7400cc32dd572ed5a1cd12cb01c5fec27b5c37950b710b279a46d60da8735154d2b2d7030 SHA512 09f3fbce633949035842cff16d2e016271b7f6abf04d74fcaa712c9b3afa18943dd566a2d88a7256a0a52d88ea689d6ef8262f6d8d67d6ea1025aa56e10300f8
+DIST odfpy-release-1.4.2.gh.tar.gz 10065808 BLAKE2B b339cb44604552ee530d8fa8385d753c1f9210f9335813ab279150b16d36f72263fc02c0d2c01ce4350dd3c81b94e7e9f394ce8ec2d85372eb972558a86ded0b SHA512 75368010c015e13302d2b43228ef9ed1f6c9307da60cf199098609729b008c69836511c953dbc730f3097124878b1fa6de7e8d5f49e20716062ada747698f84d
diff --git a/dev-python/odfpy/odfpy-1.4.2.ebuild b/dev-python/odfpy/odfpy-1.4.2.ebuild
new file mode 100644
index 000000000000..28687c31112c
--- /dev/null
+++ b/dev-python/odfpy/odfpy-1.4.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=${PN}-release-${PV}
+DESCRIPTION="Python API and tools to manipulate OpenDocument files"
+HOMEPAGE="
+ https://github.com/eea/odfpy/
+ https://pypi.org/project/odfpy/
+"
+SRC_URI="
+ https://github.com/eea/odfpy/archive/release-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+ distutils-r1_python_install_all
+}