summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-29 21:24:35 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-30 01:06:22 +0200
commita5e8e5f5a6825154bb29ea0ac2dc4860594eed79 (patch)
tree8f9780aba9c0242a52a42becad181689a52eb85e
parentnet-misc/gallery-dl: bump to 1.23.4 (diff)
downloadgentoo-a5e8e5f5.tar.gz
gentoo-a5e8e5f5.tar.bz2
gentoo-a5e8e5f5.zip
dev-python/spotipy: bump to 2.21.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-python/spotipy/Manifest1
-rw-r--r--dev-python/spotipy/spotipy-2.21.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
index 6a5da472b855..94171c508e26 100644
--- a/dev-python/spotipy/Manifest
+++ b/dev-python/spotipy/Manifest
@@ -1,2 +1,3 @@
DIST spotipy-2.19.0.tar.gz 102703 BLAKE2B bc132edb972236b43097c0bbc9d86932a3305d8bd3807e44e20767b123455950b8e01060efd83c87b3a162e329f5c48614205f131686af7f9312a44894a7f1e7 SHA512 fbaecd1a2cab3ef458d30de46cb89462021dfc3cfc85516d8bfe509af016a0b19af2f8de4f5cae36188b1ce1f5718c75edff0e71af2a87f4d720ee99d4541a6a
DIST spotipy-2.20.0.tar.gz 103437 BLAKE2B 78b026b9de04b0115c5621345e4f4c0ee47a51980221c77da8754c54fc8c321a1826983ceb9bcf9c415690906f3b3ea4657243e6b5d351d3edb48084baeca292 SHA512 8b5d0704fa84974ea0728dda0fe89d021b7b1550b464026d2b087671102745c7edcab116246399dd97de42d9c0cc7411295297c328b301712b6536aa6a3cd6fd
+DIST spotipy-2.21.0.tar.gz 105500 BLAKE2B fa49c31da93efdac23fd5cbaa31b513f48e3a90c56dee8708bf695a20c1f6040c68a22a04d6589b3a890f503d54e7c0fb017f2911ae28abe54a9e7f5bff3b540 SHA512 8783261e43962b3e98cb9b680f908d38feecf784ff404352ba16d6bb3d2e4bf1d2308b60f1437c56402e1c2a993a5bba876103f968bb8bdd81be1aef1fe6d058
diff --git a/dev-python/spotipy/spotipy-2.21.0.ebuild b/dev-python/spotipy/spotipy-2.21.0.ebuild
new file mode 100644
index 000000000000..3409dd977e02
--- /dev/null
+++ b/dev-python/spotipy/spotipy-2.21.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A light weight Python library for the Spotify Web API"
+HOMEPAGE="https://spotipy.readthedocs.io"
+SRC_URI="https://github.com/plamere/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Requires user credentials
+ rm tests/integration/test_user_endpoints.py || die
+
+ # Requires a spotify client ID
+ rm tests/integration/test_non_user_endpoints.py || die
+
+ # Needs internet access
+ sed -i -e 's:test_spotify_client_credentials_get_access_token:_&:' \
+ tests/unit/test_oauth.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples
+}