summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-01 04:40:24 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-01 05:01:20 +0200
commita5f0a4e7c14be59514db39c12580939b154da414 (patch)
tree8777223ad5bf6dc2c2f092a6ef86fc8179e9a8e9
parentdev-python/jupyter-events: Bump to 0.7.0 (diff)
downloadgentoo-a5f0a4e7c14be59514db39c12580939b154da414.tar.gz
gentoo-a5f0a4e7c14be59514db39c12580939b154da414.tar.bz2
gentoo-a5f0a4e7c14be59514db39c12580939b154da414.zip
dev-python/nbformat: Bump to 5.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/nbformat-5.9.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index 597f8f5a2d61..5103c11df179 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1,2 +1,3 @@
DIST nbformat-5.9.0.tar.gz 140980 BLAKE2B e967ac0972dd2a5749694900002f9ada4171b5219249c3b6aa600fba97121aae0334516838c86b175064b0975a298fa9a1614dd2a458dd5d66ba832187731bd4 SHA512 c409feb3b6ae9b89b86d1c5e77a23a368776ccf9e62d606e2bb689927eca4d73c79a22e3f5e9e2beda78c201dc7485114e762872b305278c23c8129c7c65449b
DIST nbformat-5.9.1.tar.gz 141100 BLAKE2B 1e9c6ed726ae534c27bf25796b23ac38d624330f219f6f5e6de6be2b80a409dee4594dd4ef8c8216aabd0ca4457417d174f83e4ee9e5f53207147dfc004219c0 SHA512 d4a36092c89e594db6d8524fa4457a1e9075d160f0a97bad767fe0f4de357d1bee76e081ddad680975803dfb7a735d2034f925555e57ac02d0436684cbcb1d8c
+DIST nbformat-5.9.2.tar.gz 141264 BLAKE2B 71f5bb447d675b10276565cb53ac193963e5161fd27e925d639e7aa63f1e69db8903974d2f924ad5456940c4b904aba33d8ab10772fdb70e7e67974a90d1f3d6 SHA512 886a03cf95b39cdca48ae46d4946cee0f3dc1f5fa0e9dac7c6184b4c3e326adb739bd9da28032868a973577aa949feb5ae95a84017755948610ef7f208ebc5db
diff --git a/dev-python/nbformat/nbformat-5.9.2.ebuild b/dev-python/nbformat/nbformat-5.9.2.ebuild
new file mode 100644
index 000000000000..d4cb983ceb55
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.9.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbformat/
+ https://pypi.org/project/nbformat/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/numpydoc \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/nbformat-5.7.1-no-node.patch"
+)
+
+EPYTEST_IGNORE=(
+ # requires pep440 package, which is not really relevant for us
+ tests/test_api.py
+)