summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-04-09 22:05:50 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-04-09 22:06:06 +0200
commita5f7949a839eeed18a4f616ea72e5661918b8c0e (patch)
treebaec50cf6eec8b46bfb8d7a62d8f5fc7762be7cb
parentdev-util/spirv-llvm-translator: fix build (diff)
downloadgentoo-a5f7949a839eeed18a4f616ea72e5661918b8c0e.tar.gz
gentoo-a5f7949a839eeed18a4f616ea72e5661918b8c0e.tar.bz2
gentoo-a5f7949a839eeed18a4f616ea72e5661918b8c0e.zip
sci-libs/gloo: add 2023.01.17
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--sci-libs/gloo/Manifest1
-rw-r--r--sci-libs/gloo/gloo-2023.01.17.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-libs/gloo/Manifest b/sci-libs/gloo/Manifest
index 97dd806d820c..c103eafd9ee1 100644
--- a/sci-libs/gloo/Manifest
+++ b/sci-libs/gloo/Manifest
@@ -1 +1,2 @@
DIST gloo-2022.05.18.tar.gz 251778 BLAKE2B 90bd97cff437d030b87c333ebb6679f199491b97826f09278b7a6740d781ca750af4e8eda18f29a4311462473146aae1fd0686443a0eb2c73e8ba34e6837b0af SHA512 356b4bd4480fda0f9db039babd223c17ed24c35945877bdb6c5b28eb45ee8ce08def73d308bc906c478c4c9d485bb0f74080d90c7a4fafe84818df0a97a7f6e2
+DIST gloo-2023.01.17.tar.gz 252199 BLAKE2B 66b5fc6786a4c07aa639a30036a21d86f43c1577a950934f558051f241d198dd3e0d7bd9da39835c5e3d617a754164cb77ae30b9bc284b0119436bf0a26f5000 SHA512 d39102ed00c813576066b755730e367337f2558a4223fe8dd127bd48882db6a97c67522782f7e7b00c36198ccd2096e61e84382358783d2edb1ca4ee55123344
diff --git a/sci-libs/gloo/gloo-2023.01.17.ebuild b/sci-libs/gloo/gloo-2023.01.17.ebuild
new file mode 100644
index 000000000000..f9c90704924d
--- /dev/null
+++ b/sci-libs/gloo/gloo-2023.01.17.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+CommitId=10909297fedab0a680799211a299203e53515032
+
+DESCRIPTION="library of floating-point neural network inference operators"
+HOMEPAGE="https://github.com/facebookincubator/gloo/"
+SRC_URI="https://github.com/facebookincubator/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libuv mpi redis ssl test"
+
+RDEPEND="
+ libuv? ( dev-libs/libuv )
+ mpi? ( virtual/mpi )
+ redis? (
+ dev-db/redis
+ dev-libs/hiredis
+ )
+ ssl? ( dev-libs/openssl:0/1.1 )
+"
+DEPEND="${RDEPEND}
+"
+
+BDEPEND="test? ( dev-cpp/gtest )"
+RESTRICT="test" # For some test the network is needed
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2022.05.18-gentoo.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TEST=$(usex test ON OFF)
+ -DUSE_LIBUV=$(usex libuv ON OFF)
+ -DUSE_MPI=$(usex mpi ON OFF)
+ -DUSE_REDIS=$(usex redis ON OFF)
+ -DUSE_TCP_OPENSSL_LINK=$(usex ssl ON OFF)
+ )
+ cmake_src_configure
+}